aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-10-31 11:40:41 -0700
committerTed Gould <ted@gould.cx>2013-10-31 11:40:41 -0700
commiteb47d698341bc8f1b46433c48fc280d5a4906ad3 (patch)
tree04e18a96bcad6c22f5079a517c5c8927d1ac49cd /src/CMakeLists.txt
parenta4a5562fd93fdd6d9cb4b9cde98126fdca3ea21d (diff)
parent0439dc69bfd71c42d01b7d11cb586ef056503b28 (diff)
downloadayatana-indicator-datetime-eb47d698341bc8f1b46433c48fc280d5a4906ad3.tar.gz
ayatana-indicator-datetime-eb47d698341bc8f1b46433c48fc280d5a4906ad3.tar.bz2
ayatana-indicator-datetime-eb47d698341bc8f1b46433c48fc280d5a4906ad3.zip
Merge trunk
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..2d51385
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,45 @@
+set (SERVICE_LIB "libindicatordatetimeservice")
+set (SERVICE_EXEC "indicator-datetime-service")
+
+add_definitions (-DTIMEZONE_FILE="/etc/timezone"
+ -DG_LOG_DOMAIN="Indicator-Datetime")
+
+# let service know how to launch gnome-control-center on the desktop
+if (BUILD_PANEL)
+ add_definitions (-DHAVE_CCPANEL)
+endif ()
+
+add_library (${SERVICE_LIB} STATIC
+ clock.c
+ clock.h
+ clock-live.c
+ clock-live.h
+ planner.c
+ planner.h
+ planner-eds.c
+ planner-eds.h
+ service.c
+ service.h
+ timezone.c
+ timezone.h
+ timezone-file.c
+ timezone-file.h
+ timezone-geoclue.c
+ timezone-geoclue.h
+ utils.c
+ utils.h
+ dbus-shared.h
+ settings-shared.h)
+include_directories (${SERVICE_DEPS_INCLUDE_DIRS})
+link_directories (${SERVICE_DEPS_LIBRARY_DIRS})
+
+add_executable (${SERVICE_EXEC} main.c)
+target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES} ${GCOV_LIBS})
+install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})
+
+# common properties
+set_property (TARGET ${SERVICE_LIB} ${SERVICE_EXEC}
+ APPEND_STRING PROPERTY COMPILE_FLAGS
+ " -g ${CC_WARNING_ARGS} ${GCOV_FLAGS}")
+
+