aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-27 16:47:49 -0600
committerTed Gould <ted@gould.cx>2011-01-27 16:47:49 -0600
commitce47d3868094c01e28fb75adecf4cd9de03832b7 (patch)
tree8bbecced83ccd6d259d2190094298bb40a28071c /src/Makefile.am
parentb7eb711886ddb2f46b0c685a577a7b0f6c455ba6 (diff)
parent28f84ee512a35e2b04b211b7c1705a6eef4368ab (diff)
downloadayatana-indicator-datetime-ce47d3868094c01e28fb75adecf4cd9de03832b7.tar.gz
ayatana-indicator-datetime-ce47d3868094c01e28fb75adecf4cd9de03832b7.tar.bz2
ayatana-indicator-datetime-ce47d3868094c01e28fb75adecf4cd9de03832b7.zip
* New upstream release.
* Change to canonical.com for naming * Fixing a type callback * Switching to GDbus and dbusmenu-0.4 * Supporting a wider range of custom strings for time and support seconds in the custom time strings. * Fixing to take time settings from LC_TIME
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am35
1 files changed, 17 insertions, 18 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ebe466d..7a290c6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,7 +4,7 @@ libexec_PROGRAMS = indicator-datetime-service
indicator_datetime_service_SOURCES = \
datetime-interface.c \
datetime-interface.h \
- datetime-service-server.h \
+ gen-datetime-service.xml.c \
calendar-menu-item.c \
calendar-menu-item.h \
datetime-service.c \
@@ -13,42 +13,41 @@ indicator_datetime_service_CFLAGS = \
-Wall \
-Werror \
$(SERVICE_CFLAGS) \
- -DTIMEZONE_FILE="\"/etc/timezone\""
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
+ -DG_LOG_DOMAIN=\"Indicator-Datetime\"
indicator_datetime_service_LDADD = \
$(SERVICE_LIBS)
datetimelibdir = $(INDICATORDIR)
datetimelib_LTLIBRARIES = libdatetime.la
libdatetime_la_SOURCES = \
- datetime-service-client.h \
+ gen-datetime-service.xml.h \
dbus-shared.h \
indicator-datetime.c
libdatetime_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
- -Wall -Werror
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Indicator-Datetime\"
libdatetime_la_LIBADD = \
$(INDICATOR_LIBS)
libdatetime_la_LDFLAGS = \
-module \
-avoid-version
-datetime-service-client.h: $(srcdir)/datetime-service.xml
- dbus-binding-tool \
- --prefix=_datetime_service_client \
- --mode=glib-client \
- --output=datetime-service-client.h \
- $(srcdir)/datetime-service.xml
+gen-%.xml.c: %.xml
+ @echo "Building $@ from $<"
+ @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
+ @echo ";" >> $@
-datetime-service-server.h: $(srcdir)/datetime-service.xml
- dbus-binding-tool \
- --prefix=_datetime_service_server \
- --mode=glib-server \
- --output=datetime-service-server.h \
- $(srcdir)/datetime-service.xml
+gen-%.xml.h: %.xml
+ @echo "Building $@ from $<"
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
BUILT_SOURCES = \
- datetime-service-client.h \
- datetime-service-server.h
+ gen-datetime-service.xml.c \
+ gen-datetime-service.xml.h
+
CLEANFILES = \
$(BUILT_SOURCES)