aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-08-30 22:03:20 -0500
committerTed Gould <ted@gould.cx>2010-08-30 22:03:20 -0500
commitdc304670cce8f0b76377c2225d5da36b1ad1ba8d (patch)
treed71acb60315c0b0b4aea3912eefb14bf52839313 /src/Makefile.am
parent3ce9af6066484f5faa6ac3a2569d7ea9fb804745 (diff)
parente22fcc15f62ec03acc0250152281f921e51a0a1b (diff)
downloadayatana-indicator-datetime-dc304670cce8f0b76377c2225d5da36b1ad1ba8d.tar.gz
ayatana-indicator-datetime-dc304670cce8f0b76377c2225d5da36b1ad1ba8d.tar.bz2
ayatana-indicator-datetime-dc304670cce8f0b76377c2225d5da36b1ad1ba8d.zip
* Upstream Merge
* Refresh times on timezone change * Update the date daily
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am31
1 files changed, 29 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fe3db2e..aadc182 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,18 +2,23 @@
libexec_PROGRAMS = indicator-datetime-service
indicator_datetime_service_SOURCES = \
+ datetime-interface.c \
+ datetime-interface.h \
+ datetime-server.h \
datetime-service.c \
dbus-shared.h
indicator_datetime_service_CFLAGS = \
-Wall \
-Werror \
- $(INDICATOR_CFLAGS)
+ $(INDICATOR_CFLAGS) \
+ -DTIMEZONE_FILE="\"/etc/timezone\""
indicator_datetime_service_LDADD = \
$(INDICATOR_LIBS)
datetimelibdir = $(INDICATORDIR)
datetimelib_LTLIBRARIES = libdatetime.la
libdatetime_la_SOURCES = \
+ datetime-client.h \
dbus-shared.h \
indicator-datetime.c
libdatetime_la_CFLAGS = \
@@ -25,4 +30,26 @@ libdatetime_la_LDFLAGS = \
-module \
-avoid-version
-EXTRA_DIST = $(libdatetime_la_SOURCES)
+datetime-service-client.h: $(srcdir)/datetime-service.xml
+ dbus-binding-tool \
+ --prefix=_datetime_service_client \
+ --mode=glib-client \
+ --output=datetime-service-client.h \
+ $(srcdir)/datetime-service.xml
+
+datetime-service-server.h: $(srcdir)/datetime-service.xml
+ dbus-binding-tool \
+ --prefix=_datetime_service_server \
+ --mode=glib-server \
+ --output=datetime-service-server.h \
+ $(srcdir)/datetime-service.xml
+
+BUILT_SOURCES = \
+ datetime-service-client.h \
+ datetime-service-server.h
+
+CLEANFILES = \
+ $(BUILT_SOURCES)
+
+EXTRA_DIST = \
+ datetime-service.xml