aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-07-07 16:23:04 -0500
committerTed Gould <ted@gould.cx>2011-07-07 16:23:04 -0500
commit1819f029c3f3af6922e095e959e80b1ce446148b (patch)
tree7f1b50533fb2363bd26918be73dd1349fadb672e /src/Makefile.am
parent7cb01301fdb2e2889d8ab8c09275c25d9dd28f01 (diff)
parent51c6800c6f718c07bd0cd016a5acdf5652f7e9c4 (diff)
downloadayatana-indicator-datetime-1819f029c3f3af6922e095e959e80b1ce446148b.tar.gz
ayatana-indicator-datetime-1819f029c3f3af6922e095e959e80b1ce446148b.tar.bz2
ayatana-indicator-datetime-1819f029c3f3af6922e095e959e80b1ce446148b.zip
Import upstream version 0.2.91
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6d388c7..6ca07a8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,7 @@
-bin_PROGRAMS = indicator-datetime-preferences
+ccpaneldir = $(CCPANELDIR)
+ccpanel_LTLIBRARIES = libindicator-datetime.la
+
libexec_PROGRAMS = indicator-datetime-service
indicator_datetime_service_SOURCES = \
@@ -34,6 +36,7 @@ libdatetime_la_SOURCES = \
libdatetime_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror \
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
libdatetime_la_LIBADD = \
$(INDICATOR_LIBS)
@@ -41,7 +44,7 @@ libdatetime_la_LDFLAGS = \
-module \
-avoid-version
-indicator_datetime_preferences_SOURCES =\
+libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
datetime-prefs-locations.c \
datetime-prefs-locations.h \
@@ -50,15 +53,17 @@ indicator_datetime_preferences_SOURCES =\
utils.c \
utils.h \
settings-shared.h
-indicator_datetime_preferences_CFLAGS = \
+libindicator_datetime_la_CFLAGS = \
-Wall \
-Werror \
-I$(top_srcdir)/libmap \
$(PREF_CFLAGS) \
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
-DPKGDATADIR="\"$(pkgdatadir)\""
-indicator_datetime_preferences_LDADD = \
+libindicator_datetime_la_LIBADD = \
$(top_builddir)/libmap/libmap.la \
$(PREF_LIBS)
+libindicator_datetime_la_LDFLAGS = -module -avoid-version
gen-%.xml.c: %.xml
@echo "Building $@ from $<"