aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-07-07 16:17:58 -0500
committerTed Gould <ted@gould.cx>2011-07-07 16:17:58 -0500
commitb64854473ee9226bc11f5b27b0057fab82a2f098 (patch)
treea64aabc5e071d3d04671fca285b13356b2c345fd /src/Makefile.am
parent62a1ba2b91d2e916c9bfc99eda0793f67af6e820 (diff)
parent5d36567ca57ebd73e7a759c83542d19b2aa8814d (diff)
downloadayatana-indicator-datetime-b64854473ee9226bc11f5b27b0057fab82a2f098.tar.gz
ayatana-indicator-datetime-b64854473ee9226bc11f5b27b0057fab82a2f098.tar.bz2
ayatana-indicator-datetime-b64854473ee9226bc11f5b27b0057fab82a2f098.zip
Making the preferences a gnome-control-center plugin instead of a stand alone app
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6d388c7..6ca07a8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,7 @@
-bin_PROGRAMS = indicator-datetime-preferences
+ccpaneldir = $(CCPANELDIR)
+ccpanel_LTLIBRARIES = libindicator-datetime.la
+
libexec_PROGRAMS = indicator-datetime-service
indicator_datetime_service_SOURCES = \
@@ -34,6 +36,7 @@ libdatetime_la_SOURCES = \
libdatetime_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror \
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
libdatetime_la_LIBADD = \
$(INDICATOR_LIBS)
@@ -41,7 +44,7 @@ libdatetime_la_LDFLAGS = \
-module \
-avoid-version
-indicator_datetime_preferences_SOURCES =\
+libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
datetime-prefs-locations.c \
datetime-prefs-locations.h \
@@ -50,15 +53,17 @@ indicator_datetime_preferences_SOURCES =\
utils.c \
utils.h \
settings-shared.h
-indicator_datetime_preferences_CFLAGS = \
+libindicator_datetime_la_CFLAGS = \
-Wall \
-Werror \
-I$(top_srcdir)/libmap \
$(PREF_CFLAGS) \
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
-DPKGDATADIR="\"$(pkgdatadir)\""
-indicator_datetime_preferences_LDADD = \
+libindicator_datetime_la_LIBADD = \
$(top_builddir)/libmap/libmap.la \
$(PREF_LIBS)
+libindicator_datetime_la_LDFLAGS = -module -avoid-version
gen-%.xml.c: %.xml
@echo "Building $@ from $<"