aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-17 16:18:45 -0600
committerTed Gould <ted@gould.cx>2012-02-17 16:18:45 -0600
commitf8ca95b2f833a22f559ccd101c612081a6a089a3 (patch)
tree70418cc37784f6f2a9c5c43639f1d2ec9723b5fc /src/Makefile.am
parent6e60a40ec583b507aef6254a744631f30f9e072d (diff)
parent52d15e402e4ada9c8f1ee1f4b7e3a9ada473772c (diff)
downloadayatana-indicator-datetime-f8ca95b2f833a22f559ccd101c612081a6a089a3.tar.gz
ayatana-indicator-datetime-f8ca95b2f833a22f559ccd101c612081a6a089a3.tar.bz2
ayatana-indicator-datetime-f8ca95b2f833a22f559ccd101c612081a6a089a3.zip
* New upstream release.
* Still need to distribute these files even if we're not building it * Adding some extra ignore stuff in * Adding in code coverage calculation * Allow ccpanel to be optional * Move to use libtimezone map * Add a name hint on the indicator * Build fixes for updated dependencies * Fixing Geoclue support
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 15 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 254022e..a31cb4b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,8 @@
+if BUILD_CCPANEL
ccpaneldir = $(CCPANELDIR)
ccpanel_LTLIBRARIES = libindicator-datetime.la
+endif
libexec_PROGRAMS = indicator-datetime-service
@@ -17,10 +19,13 @@ indicator_datetime_service_CFLAGS = \
-Wall \
-Werror \
$(SERVICE_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
indicator_datetime_service_LDADD = \
$(SERVICE_LIBS)
+indicator_datetime_service_LDFLAGS = \
+ $(COVERAGE_LDFLAGS)
datetimelibdir = $(INDICATORDIR)
datetimelib_LTLIBRARIES = libdatetime.la
@@ -33,45 +38,48 @@ libdatetime_la_SOURCES = \
indicator-datetime.c
libdatetime_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall -Werror \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
libdatetime_la_LIBADD = \
$(INDICATOR_LIBS)
libdatetime_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
-module \
-avoid-version
+if BUILD_CCPANEL
libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
datetime-prefs-locations.c \
datetime-prefs-locations.h \
- timezone-completion.c \
- timezone-completion.h \
utils.c \
utils.h \
settings-shared.h
libindicator_datetime_la_CFLAGS = \
-Wall \
-Werror \
- -I$(top_srcdir)/libmap \
$(PREF_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DPKGDATADIR="\"$(pkgdatadir)\""
libindicator_datetime_la_LIBADD = \
- $(top_builddir)/libmap/libmap.la \
$(PREF_LIBS)
-libindicator_datetime_la_LDFLAGS = -module -avoid-version
+libindicator_datetime_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
+endif
gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
BUILT_SOURCES = \
gen-datetime-service.xml.c \