aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-02-20 19:40:49 +0100
committerSebastien Bacher <seb128@ubuntu.com>2012-02-20 19:40:49 +0100
commit39bc08ed8c8c3d1be351c2642c8e2eb572a3061c (patch)
treee3fc866a6652806755760ba51dd31812299a6478 /src/Makefile.am
parent4a2175798e434a4e33def2f30e15b49714eab33b (diff)
parentade1e121d41dd07ccc81a641862d81798e38b145 (diff)
downloadayatana-indicator-datetime-39bc08ed8c8c3d1be351c2642c8e2eb572a3061c.tar.gz
ayatana-indicator-datetime-39bc08ed8c8c3d1be351c2642c8e2eb572a3061c.tar.bz2
ayatana-indicator-datetime-39bc08ed8c8c3d1be351c2642c8e2eb572a3061c.zip
releasing version 0.3.90-0ubuntu1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 15 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 254022e..a31cb4b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,8 @@
+if BUILD_CCPANEL
ccpaneldir = $(CCPANELDIR)
ccpanel_LTLIBRARIES = libindicator-datetime.la
+endif
libexec_PROGRAMS = indicator-datetime-service
@@ -17,10 +19,13 @@ indicator_datetime_service_CFLAGS = \
-Wall \
-Werror \
$(SERVICE_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
indicator_datetime_service_LDADD = \
$(SERVICE_LIBS)
+indicator_datetime_service_LDFLAGS = \
+ $(COVERAGE_LDFLAGS)
datetimelibdir = $(INDICATORDIR)
datetimelib_LTLIBRARIES = libdatetime.la
@@ -33,45 +38,48 @@ libdatetime_la_SOURCES = \
indicator-datetime.c
libdatetime_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall -Werror \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
libdatetime_la_LIBADD = \
$(INDICATOR_LIBS)
libdatetime_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
-module \
-avoid-version
+if BUILD_CCPANEL
libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
datetime-prefs-locations.c \
datetime-prefs-locations.h \
- timezone-completion.c \
- timezone-completion.h \
utils.c \
utils.h \
settings-shared.h
libindicator_datetime_la_CFLAGS = \
-Wall \
-Werror \
- -I$(top_srcdir)/libmap \
$(PREF_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DPKGDATADIR="\"$(pkgdatadir)\""
libindicator_datetime_la_LIBADD = \
- $(top_builddir)/libmap/libmap.la \
$(PREF_LIBS)
-libindicator_datetime_la_LDFLAGS = -module -avoid-version
+libindicator_datetime_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
+endif
gen-%.xml.c: %.xml
@echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
BUILT_SOURCES = \
gen-datetime-service.xml.c \