aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2015-05-20 18:23:32 -0500
committerCharles Kerr <charles.kerr@canonical.com>2015-05-20 18:23:32 -0500
commit7577ad720a9183b1a56217aeaaef01f763c11bc7 (patch)
tree294ba83581e82b13817696a50f9a3d98c800b717 /tests/CMakeLists.txt
parent45122eb294b281fb939aea315fa35ddb96cf44d1 (diff)
downloadayatana-indicator-datetime-7577ad720a9183b1a56217aeaaef01f763c11bc7.tar.gz
ayatana-indicator-datetime-7577ad720a9183b1a56217aeaaef01f763c11bc7.tar.bz2
ayatana-indicator-datetime-7577ad720a9183b1a56217aeaaef01f763c11bc7.zip
Add an EDS test for nonrepeating alarms. Refactor the EDS testing structure slightly so that more of the basic config setup can be shared.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt28
1 files changed, 14 insertions, 14 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ecbda42..d0b88b2 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -78,25 +78,25 @@ if(NOT EVOLUTION_SOURCE_SERVICE_NAME)
set(EVOLUTION_SOURCE_SERVICE_NAME "org.gnome.evolution.dataserver.Sources3")
endif()
-function(add_eds_test_by_name name)
+function(add_eds_ics_test_by_name name)
set (TEST_NAME ${name})
add_executable(${TEST_NAME} ${TEST_NAME}.cpp gschemas.compiled)
target_link_libraries (${TEST_NAME} indicatordatetimeservice gtest ${DBUSTEST_LIBRARIES} ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBS})
add_test (${TEST_NAME}
- ${CMAKE_CURRENT_SOURCE_DIR}/run-eds-test.sh
- ${DBUS_RUNNER} # arg1: dbus-test-runner exec
- ${CMAKE_CURRENT_BINARY_DIR}/${TEST_NAME} # arg2: test executable path
- ${TEST_NAME} # arg3: test name
- ${EVOLUTION_CALENDAR_FACTORY} # arg4: evolution-calendar-factory exec
- ${EVOLUTION_SOURCE_SERVICE_NAME} # arg5: dbus name for source registry
- ${EVOLUTION_SOURCE_REGISTRY} # arg6: evolution-source-registry exec
- ${GVFSD} # arg7: gvfsd exec
- ${CMAKE_CURRENT_SOURCE_DIR}/${TEST_NAME}-config-files) # arg8: canned config files
+ ${CMAKE_CURRENT_SOURCE_DIR}/run-eds-ics-test.sh
+ ${DBUS_RUNNER} # arg1: dbus-test-runner exec
+ ${CMAKE_CURRENT_BINARY_DIR}/${TEST_NAME} # arg2: test executable path
+ ${TEST_NAME} # arg3: test name
+ ${EVOLUTION_CALENDAR_FACTORY} # arg4: evolution-calendar-factory exec
+ ${EVOLUTION_SOURCE_SERVICE_NAME} # arg5: dbus name for source registry
+ ${EVOLUTION_SOURCE_REGISTRY} # arg6: evolution-source-registry exec
+ ${GVFSD} # arg7: gvfsd exec
+ ${CMAKE_CURRENT_SOURCE_DIR}/test-eds-ics-config-files # arg8: base directory for config file template
+ ${CMAKE_CURRENT_SOURCE_DIR}/${TEST_NAME}.ics) # arg9: the ical file for this test
endfunction()
-add_eds_test_by_name(test-eds-tasks)
-#add_eds_test_by_name(test-eds-valarms)
-
-
+add_eds_ics_test_by_name(test-eds-ics-repeating-events)
+add_eds_ics_test_by_name(test-eds-ics-nonrepeating-events)
+add_eds_ics_test_by_name(test-eds-ics-repeating-valarms)
# disabling the timezone unit tests because they require