aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-09-09 17:47:27 +0000
committerTarmac <Unknown>2013-09-09 17:47:27 +0000
commit03b3c04755082cf45dccf944b412d4b79aeabb72 (patch)
tree72ff6fe9d3c3bbc4bac27bdcd317067fdfb7ecdf /tests/Makefile.am
parentb7f625ed8003197cd9d0a81240aea944860c8dc3 (diff)
parent2bf6740a420f35942e9f74b7f7ef566de0ba736b (diff)
downloadayatana-indicator-datetime-03b3c04755082cf45dccf944b412d4b79aeabb72.tar.gz
ayatana-indicator-datetime-03b3c04755082cf45dccf944b412d4b79aeabb72.tar.bz2
ayatana-indicator-datetime-03b3c04755082cf45dccf944b412d4b79aeabb72.zip
name says it all; this branch is for improving indicator-datetime test coverage.
Approved by Ted Gould, PS Jenkins bot.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index dce6076..e204378 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -50,3 +50,9 @@ test_indicator_CPPFLAGS = $(TEST_CPPFLAGS) -DSCHEMA_DIR="\"$(top_builddir)/tests
###
###
###
+
+TESTS += test-utils
+check_PROGRAMS += test-utils
+test_utils_SOURCES = test-utils.cc
+test_utils_LDADD = $(top_builddir)/src/libindicator-datetime-service.a $(TEST_LIBS)
+test_utils_CPPFLAGS = $(TEST_CPPFLAGS) -DSCHEMA_DIR="\"$(top_builddir)/tests/\""