aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules68
1 files changed, 62 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 072094a..932a8d8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,70 @@
#!/usr/bin/make -f
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
+
+ifeq ($(filter nocheck,$(DEB_BUILD_PROFILES)),)
+ DEB_CMAKE_EXTRA_FLAGS += -DENABLE_TESTS=ON
+endif
%:
dh $@
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
override_dh_auto_configure:
- dh_auto_configure -- -DENABLE_TESTS=ON
-endif
+ dh_auto_configure --builddirectory=lomiri-variant \
+ --buildsystem=cmake \
+ -- \
+ $(DEB_CMAKE_EXTRA_FLAGS) \
+ -DENABLE_LOMIRI_FEATURES=ON \
+ ..
+ dh_auto_configure --builddirectory=ayatana-variant \
+ --buildsystem=cmake \
+ -- \
+ $(DEB_CMAKE_EXTRA_FLAGS) \
+ -DENABLE_LOMIRI_FEATURES=OFF \
+ ..
+
+override_dh_auto_build:
+ dh_auto_build --builddirectory=lomiri-variant \
+ --buildsystem=cmake \
+ ..
+ dh_auto_build --builddirectory=ayatana-variant \
+ --buildsystem=cmake \
+ ..
+
+override_dh_auto_test:
+ dh_auto_test --no-parallel \
+ --builddirectory=lomiri-variant \
+ --buildsystem=cmake \
+ ..
+ dh_auto_test --no-parallel \
+ --builddirectory=ayatana-variant \
+ --buildsystem=cmake \
+ ..
+
+override_dh_auto_install:
+ dh_auto_install --builddirectory=lomiri-variant \
+ --buildsystem=cmake \
+ ..
+ dh_auto_install --builddirectory=ayatana-variant \
+ --buildsystem=cmake \
+ ..
+
+override_dh_auto_clean:
+ dh_auto_clean --builddirectory=lomiri-variant \
+ --buildsystem=cmake \
+ ..
+ dh_auto_clean --builddirectory=ayatana-variant \
+ --buildsystem=cmake \
+ ..
-override_dh_install:
- dh_install --fail-missing
+override_dh_missing:
+ dh_missing --fail-missing