aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules5
3 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 21e1db3..eb74e1c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+indicator-datetime (13.10.0+14.10.20140718-0ubuntu1) utopic; urgency=low
+
+ [ Charles Kerr ]
+ * make the gcc version explicit in debian/control and debian/rules.
+
+ -- Ubuntu daily release <ps-jenkins@lists.canonical.com> Fri, 18 Jul 2014 12:06:28 +0000
+
indicator-datetime (13.10.0+14.10.20140716-0ubuntu1) utopic; urgency=low
[ Charles Kerr ]
diff --git a/debian/control b/debian/control
index 77e9241..9e7133e 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,11 @@ Source: indicator-datetime
Section: misc
Priority: optional
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
-# language-pack-en-base is for the unit tests s.t. we can test in 12h and 24h locales
+# g++-4.9: since we use c++11 features, explicitly select a g++ version
+# to protect from ABI breaks in libstdc++
+# language-pack-en-base: needed so unit tests can use 12h and 24h locales
Build-Depends: cmake,
+ g++-4.9,
dbus,
dbus-test-runner,
python3-dbusmock,
diff --git a/debian/rules b/debian/rules
index d2889aa..cf940f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,10 @@
#!/usr/bin/make -f
+# Explicitly selecting a G{CC,++}-version here to avoid accidental
+# ABI breaks introduced by toolchain updates.
+export CC=$(DEB_HOST_GNU_TYPE)-gcc-4.9
+export CXX=$(DEB_HOST_GNU_TYPE)-g++-4.9
+
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
%: