aboutsummaryrefslogtreecommitdiff
path: root/panel-gnome/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'panel-gnome/CMakeLists.txt')
-rw-r--r--panel-gnome/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/panel-gnome/CMakeLists.txt b/panel-gnome/CMakeLists.txt
index 9be4cf5..1135cd4 100644
--- a/panel-gnome/CMakeLists.txt
+++ b/panel-gnome/CMakeLists.txt
@@ -2,16 +2,19 @@ set (PANEL_LIB "gnome-indicator-datetime")
add_definitions (-DPKGDATADIR="${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}/${CMAKE_PROJECT_NAME}")
+
+SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -g ${CXX_WARNING_ARGS}")
+
add_library (${PANEL_LIB} SHARED
${CMAKE_SOURCE_DIR}/panel/datetime-prefs.c
${CMAKE_SOURCE_DIR}/panel/datetime-prefs-locations.c
${CMAKE_SOURCE_DIR}/panel/datetime-prefs-locations.h
- ${CMAKE_SOURCE_DIR}/src/utils.c
- ${CMAKE_SOURCE_DIR}/src/utils.h
- ${CMAKE_SOURCE_DIR}/src/settings-shared.h)
+ ${CMAKE_SOURCE_DIR}/src/utils.cpp
+ ${CMAKE_SOURCE_DIR}/include/datetime/utils.h
+ ${CMAKE_SOURCE_DIR}/include/datetime/settings-shared.h)
set_property (TARGET ${PANEL_LIB} PROPERTY OUTPUT_NAME indicator-datetime)
-include_directories (${PANEL_DEPS_INCLUDE_DIRS})
+include_directories (SYSTEM ${PANEL_DEPS_INCLUDE_DIRS})
link_directories (${PANEL_DEPS_LIBRARY_DIRS})