aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-13 09:11:38 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-13 09:11:38 +0200
commit04baf260b65ac95e1b4aa6f90c63e7ca06997ead (patch)
tree702bd2bc84523c6949042d98de7413261af87455 /tests/CMakeLists.txt
parent7db2204cc52bfc30fe40d22b69239b8fb6c3cd11 (diff)
parente66c68e2420ed2e2b4ce531dea46dc04b3db297b (diff)
downloadayatana-indicator-display-04baf260b65ac95e1b4aa6f90c63e7ca06997ead.tar.gz
ayatana-indicator-display-04baf260b65ac95e1b4aa6f90c63e7ca06997ead.tar.bz2
ayatana-indicator-display-04baf260b65ac95e1b4aa6f90c63e7ca06997ead.zip
Merge branch 'tari01-pr/fix-double-declaration-of-create-desktop-menu'
Attributes GH PR #26: https://github.com/AyatanaIndicators/ayatana-indicator-display/pull/26
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ecd7705..76ebd56 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -29,7 +29,7 @@ endif()
add_compile_options(${CXX_WARNING_ARGS})
-add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem)
+add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem --suppress=uninitDerivedMemberVar --suppress=unmatchedSuppression)
add_subdirectory(integration)
add_subdirectory(unit)