aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2016-03-24 16:16:53 +0000
committerCI Train Bot <ci-train-bot@canonical.com>2016-03-24 16:16:53 +0000
commite3fa9582a01f14e6d80e00d375361a76df716895 (patch)
tree7b9521ad7cfa7a2e765be265d5ecd98cb9bcad23 /tests/integration/CMakeLists.txt
parentd2f14e07000e9a5ee418bcbcd34c5ae57bd45590 (diff)
parent194d7e85a52cbc0060a2d85b71b9ddd8b606aee4 (diff)
downloadayatana-indicator-display-e3fa9582a01f14e6d80e00d375361a76df716895.tar.gz
ayatana-indicator-display-e3fa9582a01f14e6d80e00d375361a76df716895.tar.bz2
ayatana-indicator-display-e3fa9582a01f14e6d80e00d375361a76df716895.zip
When a new device appears to ADB, prompt the user whether or not to allow the connection.
Approved by: PS Jenkins bot, Charles Kerr, Xavi Garcia
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
new file mode 100644
index 0000000..9ec6688
--- /dev/null
+++ b/tests/integration/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(SERVICE_LINK_LIBRARIES
+ ${SERVICE_LIB}
+ ${SERVICE_DEPS_LIBRARIES}
+)
+set(QT_LINK_LIBRARIES
+ test-utils
+ Qt5::Core
+ Qt5::Test
+ Qt5::DBus
+)
+set(TEST_LINK_LIBRARIES
+ ${TEST_DEPS_LIBRARIES}
+ ${GTEST_LIBRARIES}
+ ${GMOCK_LIBRARIES}
+)
+
+function(add_qt_test_by_name name)
+ set(TEST_NAME ${name})
+ add_executable (${TEST_NAME} ${TEST_NAME}.cpp)
+ add_test(${TEST_NAME} ${TEST_NAME})
+ set_property(TEST ${TEST_NAME} APPEND PROPERTY ENVIRONMENT ${CTEST_ENVIRONMENT})
+ target_link_libraries(${TEST_NAME} ${SERVICE_LINK_LIBRARIES} ${QT_LINK_LIBRARIES} ${TEST_LINK_LIBRARIES} ${THREAD_LINK_LIBRARIES})
+endfunction()
+add_qt_test_by_name(usb-manager-test)