aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney Dawes <rodney.dawes@canonical.com>2017-02-10 17:08:56 +0000
committerBileto Bot <ci-train-bot@canonical.com>2017-02-10 17:08:56 +0000
commite012ca961ab230034856a64e4d24ce5db57ead6c (patch)
tree7bc93c71a46cf01b3ad153015e3c3d6f2e307549 /tests/integration/CMakeLists.txt
parent7a9c9e064e2f26a863a4474d0ae5d83e3c5b27ff (diff)
parent349c453f99aa11cea482f5078e7427e8c5e03b27 (diff)
downloadayatana-indicator-display-e012ca961ab230034856a64e4d24ce5db57ead6c.tar.gz
ayatana-indicator-display-e012ca961ab230034856a64e4d24ce5db57ead6c.tar.bz2
ayatana-indicator-display-e012ca961ab230034856a64e4d24ce5db57ead6c.zip
Make coverage reporting work.
Approved by: Pete Woods, unity-api-1-bot
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
index 9ec6688..42d710e 100644
--- a/tests/integration/CMakeLists.txt
+++ b/tests/integration/CMakeLists.txt
@@ -16,9 +16,15 @@ set(TEST_LINK_LIBRARIES
function(add_qt_test_by_name name)
set(TEST_NAME ${name})
+ set(COVERAGE_TEST_TARGETS ${COVERAGE_TEST_TARGETS} ${TEST_NAME} PARENT_SCOPE)
add_executable (${TEST_NAME} ${TEST_NAME}.cpp)
add_test(${TEST_NAME} ${TEST_NAME})
set_property(TEST ${TEST_NAME} APPEND PROPERTY ENVIRONMENT ${CTEST_ENVIRONMENT})
target_link_libraries(${TEST_NAME} ${SERVICE_LINK_LIBRARIES} ${QT_LINK_LIBRARIES} ${TEST_LINK_LIBRARIES} ${THREAD_LINK_LIBRARIES})
endfunction()
add_qt_test_by_name(usb-manager-test)
+
+set(COVERAGE_TEST_TARGETS
+ ${COVERAGE_TEST_TARGETS}
+ PARENT_SCOPE
+)