aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control34
-rw-r--r--debian/copyright21
-rwxr-xr-xdebian/rules10
5 files changed, 72 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..58b5072
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+indicator-display (0.1-0ubuntu1) utopic; urgency=medium
+
+ * Initial release.
+
+ -- Charles Kerr <charles.kerr@canonical.com> Wed, 20 Aug 2014 15:29:27 -0500
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..3c274ac
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,34 @@
+Source: indicator-display
+Section: misc
+Priority: optional
+Maintainer: Charles Kerr <charles.kerr@canonical.com>
+Build-Depends: cmake,
+ dbus,
+# make g++ version explicit for ABI safety <https://wiki.ubuntu.com/cpp-11>
+ g++-4.9,
+ libglib2.0-dev (>= 2.36),
+ libproperties-cpp-dev,
+# for coverage reports
+ lcov,
+# for tests
+ cppcheck,
+ libgtest-dev,
+ google-mock (>= 1.6.0+svn437),
+ gsettings-ubuntu-schemas (>= 0.0.2+14.10.20140813),
+# for packaging
+ debhelper (>= 9),
+ dh-translations,
+Standards-Version: 3.9.5
+Homepage: http://launchpad.net/indicator-display/
+# If you aren't a member of ~indicator-applet-developers but need to upload
+# packaging changes, just go ahead. ~indicator-applet-developers will notice and
+# sync up the code again.
+Vcs-Bzr: https://code.launchpad.net/~indicator-applet-developers/indicator-display/trunk.14.10
+
+Package: indicator-display
+Architecture: any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ gsettings-ubuntu-schemas (>= 0.0.2+14.10.20140813),
+Description: Collection of small indicators
+ Indicators too small to merit separate codebases, such as Rotation Lock
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..7809d7c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,21 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: indicator-display
+Source: http://launchpad.net/indicator-display
+
+Files: *
+Copyright: 2014, Canonical Ltd.
+License: GPL-3
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 3 of the License.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 3 can be found in "/usr/share/common-licenses/GPL-3".
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e39944a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+# Explicitly selecting a G{CC,++}-version here to avoid ABI breaks
+# introduced by toolchain updates. <https://wiki.ubuntu.com/cpp-11>
+export CC=$(DEB_HOST_GNU_TYPE)-gcc-4.9
+export CXX=$(DEB_HOST_GNU_TYPE)-g++-4.9
+
+%:
+ dh $@ --with translations
+