aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4fe7b1a..63c236d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -22,16 +22,10 @@ add_executable(
main.cpp
)
-if(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} LESS 3.2)
- set(SERVICE_THREAD_LIBS -pthread)
-else()
- set(SERVICE_THREAD_LIBS Threads::Threads)
-endif()
-
target_link_libraries(${SERVICE_EXEC}
${SERVICE_LIB}
${SERVICE_DEPS_LIBRARIES}
- ${SERVICE_THREAD_LIBS}
+ ${THREAD_LINK_LIBRARIES}
${GCOV_LIBS}
)