aboutsummaryrefslogtreecommitdiff
path: root/tests/integration/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/integration/CMakeLists.txt')
-rw-r--r--tests/integration/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/integration/CMakeLists.txt b/tests/integration/CMakeLists.txt
new file mode 100644
index 0000000..c04ecc8
--- /dev/null
+++ b/tests/integration/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(SERVICE_LINK_LIBRARIES
+ ${SERVICE_LIB}
+ ${SERVICE_DEPS_LIBRARIES}
+)
+set(QT_LINK_LIBRARIES
+ test-utils
+ Qt5::Core
+ Qt5::Test
+ Qt5::DBus
+)
+set(TEST_LINK_LIBRARIES
+ ${TEST_DEPS_LIBRARIES}
+ ${GTEST_LIBRARIES}
+ ${GMOCK_LIBRARIES}
+)
+
+function(add_qt_test_by_name name)
+ set(TEST_NAME ${name})
+ add_executable (${TEST_NAME} ${TEST_NAME}.cpp)
+ add_test(${TEST_NAME} ${TEST_NAME})
+ set_property(TEST ${TEST_NAME} APPEND PROPERTY ENVIRONMENT "${CTEST_ENVIRONMENT}")
+ target_link_libraries(${TEST_NAME} ${SERVICE_LINK_LIBRARIES} ${QT_LINK_LIBRARIES} ${TEST_LINK_LIBRARIES})
+endfunction()
+add_qt_test_by_name(usb-manager-test)