aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2024-07-08 08:57:19 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2024-07-08 08:57:19 +0200
commit340ef99748144eacf5aafa8a1d8e500a914cd8eb (patch)
tree0105c19dd9b9c8612974b238a45cace93724665e /CMakeLists.txt
parenta630e4bb274f4cc384a2a19a1b819d1834d57306 (diff)
parent6357866d6e7d479aa1a020af8f3ad11f89fcce3c (diff)
downloadayatana-indicator-keyboard-340ef99748144eacf5aafa8a1d8e500a914cd8eb.tar.gz
ayatana-indicator-keyboard-340ef99748144eacf5aafa8a1d8e500a914cd8eb.tar.bz2
ayatana-indicator-keyboard-340ef99748144eacf5aafa8a1d8e500a914cd8eb.zip
Merge branch 'tari01-pr/lomiri-session'
Attribute GH PR #70: https://github.com/AyatanaIndicators/ayatana-indicator-keyboard/pull/70
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57b01d26..a78e7e1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,7 @@ list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
# Options
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
+option(ENABLE_UBUNTU_ACCOUNTSSERVICE "Build with Ubuntu's fork of accountsservice" OFF)
set(CMAKE_BUILD_TYPE "Release")
@@ -16,6 +17,10 @@ if(ENABLE_WERROR)
add_definitions("-Werror")
endif()
+if(ENABLE_UBUNTU_ACCOUNTSSERVICE)
+ add_compile_definitions(ENABLE_UBUNTU_ACCOUNTSSERVICE)
+endif()
+
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
add_definitions("-Weverything")
else()
@@ -51,4 +56,5 @@ add_subdirectory(po)
# Display config info
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
+message(STATUS "Build with Ubuntu's fork of accountsservice: ${ENABLE_UBUNTU_ACCOUNTSSERVICE}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")