aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Hua <william.hua@canonical.com>2013-06-25 17:22:15 -0400
committerWilliam Hua <william.hua@canonical.com>2013-06-25 17:22:15 -0400
commita8b6bb97a86e61844e34a99d35a7c4b7e3f2ee05 (patch)
tree9346b816733f705a189de7b617bc9e39e4da8abc /configure.ac
parent900fadf5e6e12f21d3dedf4b0bd0636cbfca6313 (diff)
downloadayatana-indicator-keyboard-a8b6bb97a86e61844e34a99d35a7c4b7e3f2ee05.tar.gz
ayatana-indicator-keyboard-a8b6bb97a86e61844e34a99d35a7c4b7e3f2ee05.tar.bz2
ayatana-indicator-keyboard-a8b6bb97a86e61844e34a99d35a7c4b7e3f2ee05.zip
Tests work-in-progress.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dd582f47..e9bb7592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,10 @@ PKG_CHECK_MODULES([GEE], [gee-1.0])
AC_SUBST([GEE_CFLAGS])
AC_SUBST([GEE_LIBS])
+PKG_CHECK_MODULES([GIO], [gio-2.0])
+AC_SUBST([GIO_CFLAGS])
+AC_SUBST([GIO_LIBS])
+
PKG_CHECK_MODULES([GTK], [gtk+-3.0])
AC_SUBST([GTK_CFLAGS])
AC_SUBST([GTK_LIBS])
@@ -73,6 +77,10 @@ AC_CONFIG_FILES([Makefile
data/Makefile
lib/Makefile
po/Makefile.in
- tests/Makefile])
+ tests/Makefile
+ tests/config.vala
+ tests/indicator-keyboard-service
+ tests/services/indicator-keyboard.service],
+ [chmod +x tests/indicator-keyboard-service])
AC_OUTPUT