aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allan.lesage@canonical.com>2013-08-08 17:07:06 -0500
committerAllan LeSage <allan.lesage@canonical.com>2013-08-08 17:07:06 -0500
commit28c5156a3341814a7793b30686bd820b2d38d0a4 (patch)
tree5881a3c9d853708aaf9dfb6be4fbea89fc9b7795 /configure.ac
parent0e3bb46532e1858f2cfee808bd66efa225cb2d94 (diff)
downloadayatana-indicator-keyboard-28c5156a3341814a7793b30686bd820b2d38d0a4.tar.gz
ayatana-indicator-keyboard-28c5156a3341814a7793b30686bd820b2d38d0a4.tar.bz2
ayatana-indicator-keyboard-28c5156a3341814a7793b30686bd820b2d38d0a4.zip
Add gcov coverage tooling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31640e6b..d0816254 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,15 @@ PKG_CHECK_MODULES([BAMF], [libbamf3])
AC_SUBST([BAMF_CFLAGS])
AC_SUBST([BAMF_LIBS])
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
AC_CONFIG_FILES([Makefile
data/Makefile
lib/Makefile