aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorAllan LeSage <allan.lesage@canonical.com>2013-11-21 19:14:21 +0000
committerTarmac <Unknown>2013-11-21 19:14:21 +0000
commit875ee4d733ce751fcd8d974a32c4bfdebbe501a3 (patch)
tree406500af69bd6555eb4e4dc63e3711bd341bb6b4 /data/Makefile.am
parentf90c7c21d0e82779356eaa8ae471703cda45d7cc (diff)
parentbf2aab363e93263b1615f1811524fb22b14bf34b (diff)
downloadayatana-indicator-keyboard-875ee4d733ce751fcd8d974a32c4bfdebbe501a3.tar.gz
ayatana-indicator-keyboard-875ee4d733ce751fcd8d974a32c4bfdebbe501a3.tar.bz2
ayatana-indicator-keyboard-875ee4d733ce751fcd8d974a32c4bfdebbe501a3.zip
Add gcov coverage tooling; use ./autogen.sh --enable-gcov and then make coverage-html to see a report of what's covered. You can read about the rationale in this old blog post: http://qualityhour.wordpress.com/2012/01/29/test-coverage-tutorial-for-cc-autotools-projects/ .
Approved by William Hua, PS Jenkins bot.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 26e819dc..29ad3e7a 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -22,13 +22,15 @@ indicator_keyboard_icon_generator_CFLAGS = $(AM_CFLAGS) \
$(PANGOFT2_CFLAGS) \
$(GTK_CFLAGS) \
$(GNOME_DESKTOP_CFLAGS) \
- $(LIBXKLAVIER_CFLAGS)
+ $(LIBXKLAVIER_CFLAGS) \
+ $(COVERAGE_CFLAGS)
indicator_keyboard_icon_generator_LDFLAGS = $(AM_LDFLAGS) \
$(GEE_LIBS) \
$(PANGOFT2_LIBS) \
$(GTK_LIBS) \
$(GNOME_DESKTOP_LIBS) \
- $(LIBXKLAVIER_LIBS)
+ $(LIBXKLAVIER_LIBS) \
+ $(COVERAGE_LDFLAGS)
dist_service_DATA = indicator-keyboard.service
servicedir = $(DBUS_SERVICE_DIR)