aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAllan LeSage <allan.lesage@canonical.com>2013-11-21 10:37:31 -0600
committerAllan LeSage <allan.lesage@canonical.com>2013-11-21 10:37:31 -0600
commitbf2aab363e93263b1615f1811524fb22b14bf34b (patch)
tree406500af69bd6555eb4e4dc63e3711bd341bb6b4 /debian/rules
parentf10353bc4208a48339cdc1e0656361b16636a3e2 (diff)
parentf90c7c21d0e82779356eaa8ae471703cda45d7cc (diff)
downloadayatana-indicator-keyboard-bf2aab363e93263b1615f1811524fb22b14bf34b.tar.gz
ayatana-indicator-keyboard-bf2aab363e93263b1615f1811524fb22b14bf34b.tar.bz2
ayatana-indicator-keyboard-bf2aab363e93263b1615f1811524fb22b14bf34b.zip
Merge trunk, resolving Makefile conflict.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 11 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index c816d1da..d2bfba7b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,19 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
%:
dh $@ --with autoreconf,translations
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_install:
+ find debian/indicator-keyboard/usr/lib -name *.la -delete
+ find debian/indicator-keyboard/usr/lib -name *.a -delete
+ dh_install --fail-missing
+