aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-08-21 10:07:24 +0000
committerTarmac <Unknown>2013-08-21 10:07:24 +0000
commitcda797504589f647557e9188806c7248c4211f82 (patch)
tree6c60e02562945b39a25ad5c2b262d00283611803 /debian/rules
parentc7f7945238277a4a1ed209f2539f8f0b67feb35e (diff)
parente89fa16b80932a31f509ce946b9e870a51cd2d01 (diff)
downloadayatana-indicator-keyboard-cda797504589f647557e9188806c7248c4211f82.tar.gz
ayatana-indicator-keyboard-cda797504589f647557e9188806c7248c4211f82.tar.bz2
ayatana-indicator-keyboard-cda797504589f647557e9188806c7248c4211f82.zip
Packaging review.
Approved by PS Jenkins bot, Sebastien Bacher, Robert Bruce Park.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 11 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index c816d1da..d2bfba7b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,19 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
%:
dh $@ --with autoreconf,translations
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_install:
+ find debian/indicator-keyboard/usr/lib -name *.la -delete
+ find debian/indicator-keyboard/usr/lib -name *.a -delete
+ dh_install --fail-missing
+