aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index e290d9e1..5da073ca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,13 +4,17 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
%:
- dh $@ --with autoreconf
+ dh $@
override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+ NOCONFIGURE=1 ./autogen.sh
override_dh_install:
find debian/ayatana-indicator-keyboard/usr/lib -name *.la -delete