aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2012-03-21 16:49:51 -0400
committerKen VanDine <ken.vandine@canonical.com>2012-03-21 16:49:51 -0400
commit3b5f1f96c4c72df927ba4266c03ac4bec64864c0 (patch)
tree93bc7aaeb4e2a6eb6899f58a858bc172537c7ade /Makefile.am
parent2ac0106d8114b81b86bfaeabf8746375425563a2 (diff)
parentb6760ba8d8977c9ebbf0f49d427310bd8dd4d58d (diff)
downloadayatana-indicator-messages-3b5f1f96c4c72df927ba4266c03ac4bec64864c0.tar.gz
ayatana-indicator-messages-3b5f1f96c4c72df927ba4266c03ac4bec64864c0.tar.bz2
ayatana-indicator-messages-3b5f1f96c4c72df927ba4266c03ac4bec64864c0.zip
* New upstream release.
* Fix for missing icons in the messaging menu (LP: #960553) * Fix i18n for description (LP: #957525) * Implementing initial testing * Fixing blacklists (LP: #939258) * debian/control: Adding dep on libgtest-dev
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 13 insertions, 34 deletions
diff --git a/Makefile.am b/Makefile.am
index e31937a..bef67bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,18 @@ SUBDIRS = \
data \
po
+if BUILD_TESTS
+SUBDIRS += \
+ test
+
+# build src first
+test: src
+
+endif
+
+
+
+
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall --enable-deprecations
dist-hook:
@@ -33,37 +45,4 @@ dist-hook:
fi
-# Coverage targets
-
-.PHONY: clean-gcda
-clean-gcda:
- @echo Removing old coverage results
- -find -name '*.gcda' -print | xargs -r rm
-
-.PHONY: coverage-html generate-coverage-html clean-coverage-html
-coverage-html: clean-gcda
- -$(MAKE) $(AM_MAKEFLAGS) -k check
- $(MAKE) $(AM_MAKEFLAGS) generate-coverage-html
-
-generate-coverage-html:
- @echo Collecting coverage data
- $(LCOV) --directory $(top_builddir) --capture --output-file coverage.info --no-checksum --compat-libtool
- LANG=C $(GENHTML) --prefix $(top_builddir) --output-directory coveragereport --title "Code Coverage" --legend --show-details coverage.info
-
-clean-coverage-html: clean-gcda
- -$(LCOV) --directory $(top_builddir) -z
- -rm -rf coverage.info coveragereport
-
-.PHONY: coverage-xml generate-coverage-xml clean-coverage-xml
-coverage-xml: clean-gcda
- -$(MAKE) $(AM_MAKEFLAGS) -k check
- $(MAKE) $(AM_MAKEFLAGS) generate-coverage-xml
-
-generate-coverage-xml:
- @echo Generating coverage XML report
- $(GCOVR) -x -r $(top_builddir) -o $(top_builddir)/coverage.xml
-
-clean-coverage-xml: clean-gcda
- -rm -rf $(top_builddir)/coverage.xml
-
-clean-local: clean-coverage-html clean-coverage-xml
+include $(top_srcdir)/Makefile.am.coverage