aboutsummaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorPete Woods <pete.woods@canonical.com>2013-08-20 11:38:10 +0100
committerPete Woods <pete.woods@canonical.com>2013-08-20 11:38:10 +0100
commit79c89af3ac3c0c04f947c98b360a3ccaccbfc5dc (patch)
treecfc0e002b44a53eba419ad3f80b72201dde58bba /common/Makefile.am
parent94fef3bf0ca765544ef93f4a6cd38684b3ccf02e (diff)
downloadayatana-indicator-messages-79c89af3ac3c0c04f947c98b360a3ccaccbfc5dc.tar.gz
ayatana-indicator-messages-79c89af3ac3c0c04f947c98b360a3ccaccbfc5dc.tar.bz2
ayatana-indicator-messages-79c89af3ac3c0c04f947c98b360a3ccaccbfc5dc.zip
Re-do merge
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..0b8bad4
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,32 @@
+
+noinst_LTLIBRARIES = libmessaging-common.la
+
+indicator-messages-service.c: com.canonical.indicator.messages.service.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-service \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-service.h: indicator-messages-service.c
+
+indicator-messages-application.c: com.canonical.indicator.messages.application.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-application \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-application.h: indicator-messages-application.c
+
+BUILT_SOURCES = \
+ indicator-messages-service.c \
+ indicator-messages-service.h \
+ indicator-messages-application.c \
+ indicator-messages-application.h
+
+libmessaging_common_la_SOURCES = \
+ $(BUILT_SOURCES)
+
+libmessaging_common_la_CFLAGS = $(GIO_CFLAGS)
+libmessaging_common_la_LIBADD = $(GIO_LIBS)
+
+CLEANFILES = $(BUILT_SOURCES)