aboutsummaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-08-19 16:51:38 +0000
committerTarmac <Unknown>2013-08-19 16:51:38 +0000
commit8adc1d9acb001ea99937d2b8cbccb2fc4adf1ed2 (patch)
tree2d325350e2a5510a9075d207d69dc8b2f25c43d9 /common/Makefile.am
parent97d88bc9bc34f0bf654281d32c3e0aab85fa0f4d (diff)
parent41bd58d41cd15a8ca8e4499b2abe945a4fe1667d (diff)
downloadayatana-indicator-messages-8adc1d9acb001ea99937d2b8cbccb2fc4adf1ed2.tar.gz
ayatana-indicator-messages-8adc1d9acb001ea99937d2b8cbccb2fc4adf1ed2.tar.bz2
ayatana-indicator-messages-8adc1d9acb001ea99937d2b8cbccb2fc4adf1ed2.zip
Merge in phablet branch.
Approved by PS Jenkins bot, Pete Woods.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..0b8bad4
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,32 @@
+
+noinst_LTLIBRARIES = libmessaging-common.la
+
+indicator-messages-service.c: com.canonical.indicator.messages.service.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-service \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-service.h: indicator-messages-service.c
+
+indicator-messages-application.c: com.canonical.indicator.messages.application.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-application \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-application.h: indicator-messages-application.c
+
+BUILT_SOURCES = \
+ indicator-messages-service.c \
+ indicator-messages-service.h \
+ indicator-messages-application.c \
+ indicator-messages-application.h
+
+libmessaging_common_la_SOURCES = \
+ $(BUILT_SOURCES)
+
+libmessaging_common_la_CFLAGS = $(GIO_CFLAGS)
+libmessaging_common_la_LIBADD = $(GIO_LIBS)
+
+CLEANFILES = $(BUILT_SOURCES)