aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-09-16 09:07:14 -0500
committerTed Gould <ted@canonical.com>2009-09-16 09:07:14 -0500
commitddff85ec43142d492143f6a914217de1df092b8b (patch)
tree719c6662e22df88314b84d99133185d2220c4064 /configure.ac
parenta30c0ed9436d96f59dab24c58e63a45a40e91628 (diff)
parent62a047790465aaee453f1cb1cbd9042762f0486b (diff)
downloadayatana-indicator-messages-ddff85ec43142d492143f6a914217de1df092b8b.tar.gz
ayatana-indicator-messages-ddff85ec43142d492143f6a914217de1df092b8b.tar.bz2
ayatana-indicator-messages-ddff85ec43142d492143f6a914217de1df092b8b.zip
Merging in i18n branch to add i18n.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 174aec6..ee44f91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,8 @@ AM_INIT_AUTOMAKE(indicator-messages, 0.2.2)
AM_MAINTAINER_MODE
+IT_PROG_INTLTOOL([0.35.0])
+
AC_ISC_POSIX
AC_PROG_CC
AM_PROG_CC_C_O
@@ -67,6 +69,33 @@ else
fi
AC_SUBST(DBUSSERVICEDIR)
+##############################
+# Custom Junk
+##############################
+
+AC_DEFUN([AC_DEFINE_PATH], [
+ test "x$prefix" = xNONE && prefix="$ac_default_prefix"
+ test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
+ ac_define_path=`eval echo [$]$2`
+ ac_define_path=`eval echo [$]ac_define_path`
+ $1="$ac_define_path"
+ AC_SUBST($1)
+ ifelse($3, ,
+ AC_DEFINE_UNQUOTED($1, "$ac_define_path"),
+ AC_DEFINE_UNQUOTED($1, "$ac_define_path", $3))
+])
+
+###########################
+# Internationalization
+###########################
+
+GETTEXT_PACKAGE=indicator-messages
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of the default get text domain])
+AC_DEFINE_PATH(GNOMELOCALEDIR, "${datadir}/locale", [locale directory])
+
+AM_GLIB_GNU_GETTEXT
+
###########################
# Files
###########################
@@ -88,6 +117,7 @@ data/icons/48x48/Makefile
data/icons/48x48/status/Makefile
data/icons/scalable/Makefile
data/icons/scalable/status/Makefile
+po/Makefile.in
])
###########################