aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-08-23 13:28:52 +0200
committerSebastien Bacher <seb128@ubuntu.com>2012-08-23 13:28:52 +0200
commitda454128c64f7228d1263c3d7395187daf90debc (patch)
tree3ae993ede02dea1f67497ab721a98e47d76efd87 /configure.ac
parent7290a3b470600e43c2e700395e3620c4a4d5056d (diff)
parent9d8a4eeaf93b5f5537558e925a1c4f9b16e772b7 (diff)
downloadayatana-indicator-messages-da454128c64f7228d1263c3d7395187daf90debc.tar.gz
ayatana-indicator-messages-da454128c64f7228d1263c3d7395187daf90debc.tar.bz2
ayatana-indicator-messages-da454128c64f7228d1263c3d7395187daf90debc.zip
* New upstream version
* debian/control: - set some conflicts on the old deprecated status provider binaries - updated Build-Depends * debian/control, debian/*.install: - drop indicator-status-provider-*, those are deprecated - new binaries for the libmessaging-menu library * debian/libmessaging-menu0.symbols: - symbol file for the new library * Updated packaging to dh9, current standards
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac101
1 files changed, 34 insertions, 67 deletions
diff --git a/configure.ac b/configure.ac
index 6d286bb..f9f00e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
-AC_INIT(src/indicator-messages.c)
+AC_INIT(indicator-messages, 12.10.0)
-AC_PREREQ(2.53)
+AC_PREREQ(2.62)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-messages, 0.6.0)
+AM_INIT_AUTOMAKE()
AM_MAINTAINER_MODE
@@ -38,74 +38,29 @@ AC_PROG_CXX
# Dependencies
###########################
-GTK_REQUIRED_VERSION=2.12
-GTK3_REQUIRED_VERSION=3.0
+GTK_REQUIRED_VERSION=3.0
GIO_UNIX_REQUIRED_VERSION=2.18
PANEL_REQUIRED_VERSION=2.0.0
-INDICATE_REQUIRED_VERSION=0.6.90
INDICATOR_REQUIRED_VERSION=0.3.19
-DBUSMENUGTK_REQUIRED_VERSION=0.5.90
GLIB_REQUIRED_VERSION=2.31.20
+INTROSPECTION_REQUIRED_VERSION=1.32.0
-AC_ARG_WITH([gtk],
- [AS_HELP_STRING([--with-gtk],
- [Which version of gtk to use for the indicator @<:@default=3@:>@])],
- [],
- [with_gtk=3])
-
-AS_IF([test "x$with_gtk" = x3],
- [PKG_CHECK_MODULES(APPLET, gtk+-3.0 >= $GTK3_REQUIRED_VERSION
- gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION
- indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
- indicate-0.7 >= $INDICATE_REQUIRED_VERSION
- dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- glib-2.0 >= $GLIB_REQUIRED_VERSION
- gmodule-2.0 >= $GLIB_REQUIRED_VERSION)
- ],
- [test "x$with_gtk" = x2],
- [PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
- gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION
- indicator-0.4 >= $INDICATOR_REQUIRED_VERSION
- indicate-0.7 >= $INDICATE_REQUIRED_VERSION
- dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- glib-2.0 >= $GLIB_REQUIRED_VERSION
- gmodule-2.0 >= $GLIB_REQUIRED_VERSION)
- ],
- [AC_MSG_FAILURE([Value for --with-indicator-gtk was neither 2 nor 3])]
-)
-AC_SUBST(APPLET_CFLAGS)
-AC_SUBST(APPLET_LIBS)
+PKG_CHECK_MODULES(APPLET, gtk+-3.0 >= $GTK_REQUIRED_VERSION
+ gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION
+ indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gmodule-2.0 >= $GLIB_REQUIRED_VERSION)
-###########################
-# Test Dependencies
-###########################
-
-AC_ARG_ENABLE([tests],
- AC_HELP_STRING([--disable-tests], [Disable test scripts and tools]),,
- [enable_tests=auto])
-AM_CONDITIONAL(BUILD_TESTS, test xyes = xyes)
+PKG_CHECK_MODULES(GIO, gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
-###########################
-# Status Provider Deps
-###########################
-
-PKG_CHECK_MODULES(STATUS_PROVIDER_PIDGIN, dbus-glib-1)
-AC_SUBST(STATUS_PROVIDER_PIDGIN_CFLAGS)
-AC_SUBST(STATUS_PROVIDER_PIDGIN_LIBS)
+AC_SUBST(APPLET_CFLAGS)
+AC_SUBST(APPLET_LIBS)
-PKG_CHECK_MODULES(STATUS_PROVIDER_TELEPATHY, dbus-glib-1)
-AC_SUBST(STATUS_PROVIDER_TELEPATHY_CFLAGS)
-AC_SUBST(STATUS_PROVIDER_TELEPATHY_LIBS)
+GLIB_GSETTINGS
-TELEPATHYGLIB_REQUIRED_VERSION=0.9.0
-PKG_CHECK_MODULES(STATUS_PROVIDER_MC5, dbus-glib-1
- telepathy-glib >= $TELEPATHYGLIB_REQUIRED_VERSION)
-AC_SUBST(STATUS_PROVIDER_MC5_CFLAGS)
-AC_SUBST(STATUS_PROVIDER_MC5_LIBS)
+GTK_DOC_CHECK([1.18], [])
-PKG_CHECK_MODULES(STATUS_PROVIDER_EMESENE, dbus-glib-1)
-AC_SUBST(STATUS_PROVIDER_EMESENE_CFLAGS)
-AC_SUBST(STATUS_PROVIDER_EMESENE_LIBS)
+GOBJECT_INTROSPECTION_CHECK([$INTROSPECTION_REQUIRED_VERSION])
###########################
# gcov coverage reporting
@@ -124,8 +79,20 @@ AC_SUBST(COVERAGE_LDFLAGS)
# Google Test framework
###########################
-m4_include([m4/gtest.m4])
-CHECK_GTEST
+AC_ARG_ENABLE([tests],
+ [AS_HELP_STRING([--disable-tests], [Disable test scripts and tools (default=auto)])],
+ [enable_tests=${enableval}],
+ [enable_tests=auto])
+if test "x$enable_tests" != "xno"; then
+ m4_include([m4/gtest.m4])
+ CHECK_GTEST
+ if test "x$enable_tests" = "xauto"; then
+ enable_tests=${have_gtest}
+ elif test "x$enable_tests" = "xyes" && test "x$have_gtest" != "xyes"; then
+ AC_MSG_ERROR([tests were requested but gtest is not installed.])
+ fi
+fi
+AM_CONDITIONAL([BUILD_TESTS],[test "x$enable_tests" = "xyes"])
###########################
# Check to see if we're local
@@ -141,9 +108,6 @@ AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all
if test "x$with_localinstall" = "xyes"; then
INDICATORDIR="${libdir}/indicators/2/"
INDICATORICONSDIR="${datadir}/libindicate/icons/"
-elif test "x$with_gtk" = x2; then
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator-0.4`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator-0.4`
else
INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3-0.4`
@@ -196,7 +160,6 @@ AM_GLIB_GNU_GETTEXT
AC_OUTPUT([
Makefile
src/Makefile
-src/indicator-messages-status-provider-0.5.pc.in
data/Makefile
data/icons/Makefile
data/icons/16x16/Makefile
@@ -217,6 +180,8 @@ data/icons/scalable/status/Makefile
data/icons/scalable/categories/Makefile
po/Makefile.in
test/Makefile
+libmessaging-menu/Makefile
+libmessaging-menu/messaging-menu.pc
])
###########################
@@ -229,5 +194,7 @@ Messaging Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
+ gtest: $enable_tests
gcov: $use_gcov
+ introspecion: $enable_introspection
])