aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-04-08 16:24:27 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-04-08 16:24:27 +0000
commit8782213594a5d08cb16a964dec3e3232cae18b24 (patch)
treed2750a81e7b03591401e722e5e6024c10cca7901 /data/upstart/Makefile.am
parent67c7bc304d79f9cd61370430de172acb6a2f7834 (diff)
parent36018e660bc33af6a126418ec952baabcf4da340 (diff)
downloadayatana-indicator-messages-8782213594a5d08cb16a964dec3e3232cae18b24.tar.gz
ayatana-indicator-messages-8782213594a5d08cb16a964dec3e3232cae18b24.tar.bz2
ayatana-indicator-messages-8782213594a5d08cb16a964dec3e3232cae18b24.zip
Synchronize process management across indicators
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 0000000..c182438
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,12 @@
+
+xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+xdg_autostart_DATA = indicator-messages.desktop
+
+%.desktop: %.desktop.in
+ $(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
+EXTRA_DIST = \
+ indicator-messages.desktop.in
+
+CLEANFILES = \
+ $(xdg_autostart_DATA)