aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-02-24 12:41:07 -0500
committerKen VanDine <ken.vandine@canonical.com>2011-02-24 12:41:07 -0500
commitcb170c0fb193360740cc543816e6f00d46a480c7 (patch)
tree15a84f9d1efbdebc6e97a573071b2c1609850d15 /debian
parentf6d9b2566d4ef31a54505c4998ce1881516799b2 (diff)
downloadayatana-indicator-messages-cb170c0fb193360740cc543816e6f00d46a480c7.tar.gz
ayatana-indicator-messages-cb170c0fb193360740cc543816e6f00d46a480c7.tar.bz2
ayatana-indicator-messages-cb170c0fb193360740cc543816e6f00d46a480c7.zip
releasing version 0.3.92-0ubuntu3
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
-rw-r--r--debian/control2
-rw-r--r--debian/patches/lp_690668.patch44
-rw-r--r--debian/patches/series1
-rw-r--r--debian/source/format1
5 files changed, 59 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d3ec23d..3970d34 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+indicator-messages (0.3.92-0ubuntu3) natty; urgency=low
+
+ * debian/patches/lp_690668.patch
+ - Memory leak fixes (LP: #690668)
+ * debian/control
+ - Bump standards version to 3.9.1
+ * debian/source/format
+ - Use source format 3.0 (quilt)
+
+ -- Ken VanDine <ken.vandine@canonical.com> Thu, 24 Feb 2011 12:13:33 -0500
+
indicator-messages (0.3.92-0ubuntu2) natty; urgency=low
* src/launcher-menu-item.c
@@ -42,6 +53,7 @@ indicator-messages (0.3.90-0ubuntu1) natty; urgency=low
-- Ken VanDine <ken.vandine@canonical.com> Fri, 14 Jan 2011 14:50:30 -0600
indicator-messages (0.3.11-0ubuntu4) natty; urgency=low
+
* debian/control
- Bump build depends for libdbusmenu-* to >= 0.3.90
diff --git a/debian/control b/debian/control
index dbebc17..e299361 100644
--- a/debian/control
+++ b/debian/control
@@ -16,7 +16,7 @@ Build-Depends: debhelper (>= 5.0),
libindicator-dev (>= 0.3.19),
libdbusmenu-gtk-dev (>= 0.3.94),
libdbusmenu-glib-dev (>= 0.3.94)
-Standards-Version: 3.8.4
+Standards-Version: 3.9.1
Homepage: https://launchpad.net/indicator-messages
Vcs-Bzr: http://code.launchpad.net/~ubuntu-desktop/indicator-messages/ubuntu
Vcs-Browser: http://bazaar.launchpad.net/~ubuntu-desktop/indicator-messages/ubuntu/files
diff --git a/debian/patches/lp_690668.patch b/debian/patches/lp_690668.patch
new file mode 100644
index 0000000..48ee7f5
--- /dev/null
+++ b/debian/patches/lp_690668.patch
@@ -0,0 +1,44 @@
+=== modified file 'src/indicator-messages.c'
+--- old/src/indicator-messages.c 2011-01-14 19:10:10 +0000
++++ new/src/indicator-messages.c 2011-01-21 20:08:53 +0000
+@@ -571,6 +571,7 @@
+ width,
+ height,
+ GDK_INTERP_BILINEAR);
++ g_object_unref(pixbuf);
+ } else {
+ g_debug("Happy with icon sized %dx%d", gdk_pixbuf_get_width(pixbuf), gdk_pixbuf_get_height(pixbuf));
+ resized_pixbuf = pixbuf;
+@@ -578,10 +579,7 @@
+
+ gtk_image_set_from_pixbuf(GTK_IMAGE(mi_data->icon), resized_pixbuf);
+
+- /* The other pixbuf should be free'd by the dbusmenu. */
+- if (resized_pixbuf != pixbuf) {
+- g_object_unref(resized_pixbuf);
+- }
++ g_object_unref(resized_pixbuf);
+
+ gtk_widget_show(mi_data->icon);
+ } else {
+@@ -633,6 +631,7 @@
+ width,
+ height,
+ GDK_INTERP_BILINEAR);
++ g_object_unref(pixbuf);
+ } else {
+ g_debug("Happy with icon sized %dx%d", gdk_pixbuf_get_width(pixbuf), gdk_pixbuf_get_height(pixbuf));
+ resized_pixbuf = pixbuf;
+@@ -640,10 +639,7 @@
+
+ gtk_image_set_from_pixbuf(GTK_IMAGE(mi_data->icon), resized_pixbuf);
+
+- /* The other pixbuf should be free'd by the dbusmenu. */
+- if (resized_pixbuf != pixbuf) {
+- g_object_unref(resized_pixbuf);
+- }
++ g_object_unref(resized_pixbuf);
+ }
+ gtk_misc_set_alignment(GTK_MISC(mi_data->icon), 0.0, 0.5);
+ gtk_box_pack_start(GTK_BOX(hbox), mi_data->icon, FALSE, FALSE, padding);
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..6badc75
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+lp_690668.patch
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)