aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-07-08 09:22:34 -0500
committerTed Gould <ted@gould.cx>2011-07-08 09:22:34 -0500
commitd3fd0cd48d7455e4cbc103b52165c2551f396365 (patch)
tree1fbd307d08a216ae2af0d68945023b1ea9bb18fe /debian
parent8fa33012e926fb370e9119199e0724665e85c6c8 (diff)
parent98391ec779a9a6393206eb0b87197f4edce00f64 (diff)
downloadayatana-indicator-messages-d3fd0cd48d7455e4cbc103b52165c2551f396365.tar.gz
ayatana-indicator-messages-d3fd0cd48d7455e4cbc103b52165c2551f396365.tar.bz2
ayatana-indicator-messages-d3fd0cd48d7455e4cbc103b52165c2551f396365.zip
Sync to U. Desktop
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog25
-rw-r--r--debian/control21
-rw-r--r--debian/indicator-messages-gtk2.install1
-rw-r--r--debian/indicator-messages.install1
-rwxr-xr-xdebian/rules21
5 files changed, 60 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 3b90087..dacbf7d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,30 @@
-indicator-messages (0.4.90-0ubuntu1~ppa1) oneiric; urgency=low
+indicator-messages (0.4.90-0ubuntu2) oneiric; urgency=low
+ * Rebuild for libdbusmenu-gtk3-4
+ * debian/control
+ - Removed duplicate build depends
+ - Dropped build depends on indicator-messages-gtk2
+
+ -- Ken VanDine <ken.vandine@canonical.com> Tue, 28 Jun 2011 09:01:12 -0400
+
+indicator-messages (0.4.90-0ubuntu1) oneiric; urgency=low
+
+ [ Ted Gould ]
* New upstream release.
* GTK 3
- -- Ted Gould <ted@ubuntu.com> Tue, 21 Jun 2011 15:58:35 -0500
+ [ Ken VanDine ]
+ * debian/control
+ - Bumped standards version to 3.9.2
+ - Add new binary for indicator-messages-gtk2
+ - Make indicator-messages recommend indicator-messages-gtk2 (until unity
+ can load gtk3 indicators)
+ - indicator-messages-gtk2 replaces indicator-messages << 0.4.90
+ - Added build depends for libdbusmenu-gtk3-dev and libindicator3-dev
+ * debian/rules
+ - build for both gtk2 and gtk3
+
+ -- Ken VanDine <ken.vandine@canonical.com> Wed, 22 Jun 2011 12:34:43 -0400
indicator-messages (0.4.0-0ubuntu1) natty; urgency=low
diff --git a/debian/control b/debian/control
index e299361..89a09b8 100644
--- a/debian/control
+++ b/debian/control
@@ -7,6 +7,7 @@ Uploaders: Evgeni Golov <evgeni@debian.org>
Build-Depends: debhelper (>= 5.0),
cdbs (>= 0.4.41),
libgtk2.0-dev (>= 2.12.0),
+ libgtk-3-dev,
libdbus-glib-1-dev,
gnome-doc-utils,
scrollkeeper,
@@ -14,9 +15,11 @@ Build-Depends: debhelper (>= 5.0),
libindicate-dev (>= 0.4.91),
libindicate-gtk-dev (>= 0.4.91),
libindicator-dev (>= 0.3.19),
+ libindicator3-dev (>= 0.3.19),
+ libdbusmenu-glib-dev (>= 0.3.94),
libdbusmenu-gtk-dev (>= 0.3.94),
- libdbusmenu-glib-dev (>= 0.3.94)
-Standards-Version: 3.9.1
+ libdbusmenu-gtk3-dev (>= 0.3.94)
+Standards-Version: 3.9.2
Homepage: https://launchpad.net/indicator-messages
Vcs-Bzr: http://code.launchpad.net/~ubuntu-desktop/indicator-messages/ubuntu
Vcs-Browser: http://bazaar.launchpad.net/~ubuntu-desktop/indicator-messages/ubuntu/files
@@ -31,3 +34,17 @@ Description: indicator that collects messages that need a response
This menu provides a condensed and collected view of all of those messages
for quick access, but without making them annoying in times that you want
to ignore them.
+
+Package: indicator-messages-gtk2
+Architecture: any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ indicator-messages (= ${binary:Version})
+Recommends: indicator-applet | indicator-renderer
+Replaces: indicator-messages (<< 0.4.90)
+Breaks: indicator-applet (<< 0.3.0)
+Description: indicator that collects messages that need a response
+ A place on the user's desktop that collects messages that need a response.
+ This menu provides a condensed and collected view of all of those messages
+ for quick access, but without making them annoying in times that you want
+ to ignore them.
diff --git a/debian/indicator-messages-gtk2.install b/debian/indicator-messages-gtk2.install
new file mode 100644
index 0000000..8d1fc9f
--- /dev/null
+++ b/debian/indicator-messages-gtk2.install
@@ -0,0 +1 @@
+debian/tmp/gtk2/usr/lib/indicators /usr/lib/
diff --git a/debian/indicator-messages.install b/debian/indicator-messages.install
new file mode 100644
index 0000000..19a45de
--- /dev/null
+++ b/debian/indicator-messages.install
@@ -0,0 +1 @@
+debian/tmp/gtk3/usr /
diff --git a/debian/rules b/debian/rules
index e813915..219cf64 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,23 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-DEB_CONFIGURE_EXTRA_FLAGS += --disable-scrollkeeper
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
+
+DEB_CONFIGURE_FLAGS_gtk2 = --with-indicator-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-indicator-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-binary-install/indicator-messages::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
+
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete