aboutsummaryrefslogtreecommitdiff
path: root/doc/reference/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-09-01 12:35:36 +0200
committerSebastien Bacher <seb128@ubuntu.com>2012-09-01 12:35:36 +0200
commit38c23eb353e046bed03aa3a196079ad6c529c5fc (patch)
treefe03bb7db005946847e3918b2a418900cdb8d0f8 /doc/reference/Makefile.am
parent189472aa40bbdc6bc9f9676202ced5bd2eb5e099 (diff)
parentc8794795a7054eff4e21bbca52321195f2d8720c (diff)
downloadayatana-indicator-messages-38c23eb353e046bed03aa3a196079ad6c529c5fc.tar.gz
ayatana-indicator-messages-38c23eb353e046bed03aa3a196079ad6c529c5fc.tar.bz2
ayatana-indicator-messages-38c23eb353e046bed03aa3a196079ad6c529c5fc.zip
* New upstream release, includes apis to allow changing the label and
the icon of sources and add documentation * debian/libmessaging-menu0.symbols: - new version update * debian/libmessaging-menu-dev.install: - install the documentation * debian/rules: - build the documentation - updated shlibs version - use --with gir so gir:Depends work as it should (lp: #1044125)
Diffstat (limited to 'doc/reference/Makefile.am')
-rw-r--r--doc/reference/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/doc/reference/Makefile.am b/doc/reference/Makefile.am
new file mode 100644
index 0000000..023f1e7
--- /dev/null
+++ b/doc/reference/Makefile.am
@@ -0,0 +1,21 @@
+DOC_MODULE = messaging-menu
+
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
+
+DOC_SOURCE_DIR = $(top_srcdir)/libmessaging-menu
+
+SCANGOBJ_OPTIONS=--type-init-func="g_type_init()"
+MKDB_OPTIONS=--xml-mode --output-format=xml
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+HFILE_GLOB = $(top_srcdir)/libmessaging-menu/*.h
+CFILE_GLOB = $(top_srcdir)/libmessaging-menu/*.c
+
+IGNORE_HFILES= \
+ indicator-messages-service.h \
+ gtupleaction.h
+
+INCLUDES=-I$(top_srcdir)/libmessaging-menu $(GIO_CFLAGS)
+GTKDOC_LIBS=$(top_builddir)/libmessaging-menu/libmessaging-menu.la
+
+include $(top_srcdir)/gtk-doc.make