aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-02-10 17:44:16 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-02-10 17:44:16 +0100
commit07a19cb993cacaf3a1185f1268334a6f6d3e744f (patch)
tree053f608ca6e1736da5a852734b539f54cb742893 /src/Makefile.am
parent981c01a3442a6a0a459ac313e29486b67aa1aac7 (diff)
parent1f045f4255da09068f5fbbdf89f178631211f2ee (diff)
downloadayatana-indicator-messages-07a19cb993cacaf3a1185f1268334a6f6d3e744f.tar.gz
ayatana-indicator-messages-07a19cb993cacaf3a1185f1268334a6f6d3e744f.tar.bz2
ayatana-indicator-messages-07a19cb993cacaf3a1185f1268334a6f6d3e744f.zip
Merge trunk
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9da71ad..6617b49 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,6 +20,7 @@ libmessaging_la_SOURCES = \
dbus-data.h
libmessaging_la_CFLAGS = \
$(APPLET_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -27,7 +28,9 @@ libmessaging_la_CFLAGS = \
-Werror \
-DG_LOG_DOMAIN=\"Indicator-Messages\"
libmessaging_la_LIBADD = $(APPLET_LIBS) -lm
-libmessaging_la_LDFLAGS = -module -avoid-version
+libmessaging_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
######################################
# Building the messages service
@@ -57,6 +60,7 @@ indicator_messages_service_SOURCES = \
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -69,6 +73,9 @@ indicator_messages_service_LDADD = \
$(APPLET_LIBS) \
libindicator-messages-status-provider.la
+indicator_messages_service_LDFLAGS = \
+ $(COVERAGE_LDFLAGS)
+
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
@echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@