aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-05-28 10:19:48 -0500
committerTed Gould <ted@canonical.com>2009-05-28 10:19:48 -0500
commit0ea6c2853010c71fb66ea6ec0cf9d9540db50c09 (patch)
treed148546e65f58974ab14b8bf073771ed0db81fd4 /src/Makefile.am
parent72f0924b3a78b75176cbbadd6cfb827f592ee94f (diff)
downloadayatana-indicator-messages-0ea6c2853010c71fb66ea6ec0cf9d9540db50c09.tar.gz
ayatana-indicator-messages-0ea6c2853010c71fb66ea6ec0cf9d9540db50c09.tar.bz2
ayatana-indicator-messages-0ea6c2853010c71fb66ea6ec0cf9d9540db50c09.zip
Failing on warnings
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c543e48..74db2df 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,10 +4,10 @@ bin_PROGRAMS = indicator-messages-service
messaginglibdir = $(INDICATORDIR)
messaginglib_LTLIBRARIES = libmessaging.la
libmessaging_la_SOURCES = indicator-messages.c im-menu-item.c im-menu-item.h app-menu-item.c app-menu-item.h
-libmessaging_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Wl,-Bsymbolic-functions -Wl,-z,defs -Wl,--as-needed
+libmessaging_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Wl,-Bsymbolic-functions -Wl,-z,defs -Wl,--as-needed -Werror
libmessaging_la_LIBADD = $(APPLET_LIBS)
libmessaging_la_LDFLAGS = -module -avoid-version
indicator_messages_service_SOURCES = indicator-service.c im-menu-item.c im-menu-item.h app-menu-item.c app-menu-item.h
-indicator_messages_service_CFLAGS = $(APPLET_CFLAGS) -Wall -Wl,-Bsymbolic-functions -Wl,-z,defs -Wl,--as-needed
+indicator_messages_service_CFLAGS = $(APPLET_CFLAGS) -Wall -Wl,-Bsymbolic-functions -Wl,-z,defs -Wl,--as-needed -Werror
indicator_messages_service_LDADD = $(APPLET_LIBS)