aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-08-20 21:32:33 +0200
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-08-20 21:32:33 +0200
commit004314963a36bb48473ae58eccc9f5532225ab9b (patch)
tree9747d0a1af2ef75805654c393f2d241caee75bcf /src/Makefile.am
parent8be3201de7ac246e759f74bfe35e53f742908800 (diff)
downloadayatana-indicator-messages-004314963a36bb48473ae58eccc9f5532225ab9b.tar.gz
ayatana-indicator-messages-004314963a36bb48473ae58eccc9f5532225ab9b.tar.bz2
ayatana-indicator-messages-004314963a36bb48473ae58eccc9f5532225ab9b.zip
Use a custom menu item for application items
This introduces ImAppMenuItem: a menu item which shows a small triangle next to an application's name if the associated app is running. The running state is communicated to the menu by giving the "launch" action a boolean state. This depends on a patch to gtk which creates custom menu items from gtk_menu_new_from_model when the x-canonical-type attribute is set on a menu item in the model.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1bc5b59..37009b7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,6 +15,8 @@ messaginglibdir = $(INDICATORDIR)
messaginglib_LTLIBRARIES = libmessaging.la
libmessaging_la_SOURCES = \
indicator-messages.c \
+ im-app-menu-item.c \
+ im-app-menu-item.h \
indicator-messages-service.c \
indicator-messages-service.h
dbus-data.h