aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2012-02-10 10:33:11 -0500
committerKen VanDine <ken.vandine@canonical.com>2012-02-10 10:33:11 -0500
commit1fc19f1fb5eeaf7b3a600f4783e66ff75e092d56 (patch)
tree8d70f1e282c2677c71b52395a90f219497325169 /src/Makefile.am
parent4aacdd9668a570edcd9a8654865f147dcab396fe (diff)
parent081237a24c34a9462c47a2d62720ba14f18cad0e (diff)
downloadayatana-indicator-messages-1fc19f1fb5eeaf7b3a600f4783e66ff75e092d56.tar.gz
ayatana-indicator-messages-1fc19f1fb5eeaf7b3a600f4783e66ff75e092d56.tar.bz2
ayatana-indicator-messages-1fc19f1fb5eeaf7b3a600f4783e66ff75e092d56.zip
* New upstream release.
* Adding code coverage targets * Match libindicate 0.6.90 * Updating for Dbusmenu 0.5.90 * Plug leak in launcher_menu_item_new * Fix memory leak: Free path string. * Compare server and path for multi-server clients * Using the new GTK3 box API to avoid deprecations * Adding a name hint * debian/control: Requiring libindicate 0.6.90 and dbusmenu 0.5.90
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c631436..33473db 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,6 +20,7 @@ libmessaging_la_SOURCES = \
dbus-data.h
libmessaging_la_CFLAGS = \
$(APPLET_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -27,7 +28,9 @@ libmessaging_la_CFLAGS = \
-Werror \
-DG_LOG_DOMAIN=\"Indicator-Messages\"
libmessaging_la_LIBADD = $(APPLET_LIBS)
-libmessaging_la_LDFLAGS = -module -avoid-version
+libmessaging_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
######################################
# Building the messages service
@@ -57,6 +60,7 @@ indicator_messages_service_SOURCES = \
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -69,6 +73,9 @@ indicator_messages_service_LDADD = \
$(APPLET_LIBS) \
libindicator-messages-status-provider.la
+indicator_messages_service_LDFLAGS = \
+ $(COVERAGE_LDFLAGS)
+
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
@echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@