aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-09 22:35:01 -0600
committerTed Gould <ted@gould.cx>2012-02-09 22:35:01 -0600
commit6a357cabcd97060ffcef856c06d406614bbfc19d (patch)
tree39af400c2584d75fd036b223d98c4553bd436b53 /src/Makefile.am
parent84a1d59e2a031e072721e976974443ad37ff4c64 (diff)
parent1f045f4255da09068f5fbbdf89f178631211f2ee (diff)
downloadayatana-indicator-messages-6a357cabcd97060ffcef856c06d406614bbfc19d.tar.gz
ayatana-indicator-messages-6a357cabcd97060ffcef856c06d406614bbfc19d.tar.bz2
ayatana-indicator-messages-6a357cabcd97060ffcef856c06d406614bbfc19d.zip
Import upstream version 0.5.90
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c631436..33473db 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -20,6 +20,7 @@ libmessaging_la_SOURCES = \
dbus-data.h
libmessaging_la_CFLAGS = \
$(APPLET_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -27,7 +28,9 @@ libmessaging_la_CFLAGS = \
-Werror \
-DG_LOG_DOMAIN=\"Indicator-Messages\"
libmessaging_la_LIBADD = $(APPLET_LIBS)
-libmessaging_la_LDFLAGS = -module -avoid-version
+libmessaging_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
######################################
# Building the messages service
@@ -57,6 +60,7 @@ indicator_messages_service_SOURCES = \
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -69,6 +73,9 @@ indicator_messages_service_LDADD = \
$(APPLET_LIBS) \
libindicator-messages-status-provider.la
+indicator_messages_service_LDFLAGS = \
+ $(COVERAGE_LDFLAGS)
+
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
@echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@