aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPete Woods <pete.woods@canonical.com>2013-08-21 16:04:53 +0000
committerTarmac <Unknown>2013-08-21 16:04:53 +0000
commit933deb6d32c36e8bf6db23d5673982cab788337a (patch)
treebe808298ec80ca3dc6d73309ac9e1e7024ee7950 /src/Makefile.am
parent94fef3bf0ca765544ef93f4a6cd38684b3ccf02e (diff)
parent046f655a8859e2e3eaa6015fc2ecd226c8b46b1f (diff)
downloadayatana-indicator-messages-933deb6d32c36e8bf6db23d5673982cab788337a.tar.gz
ayatana-indicator-messages-933deb6d32c36e8bf6db23d5673982cab788337a.tar.bz2
ayatana-indicator-messages-933deb6d32c36e8bf6db23d5673982cab788337a.zip
Re-merge the consolidate branch, but with additional bugfix.
Approved by Sebastien Bacher, PS Jenkins bot.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am73
1 files changed, 13 insertions, 60 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1df80e5..9b1cc9a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,53 +1,10 @@
-BUILT_SOURCES =
EXTRA_DIST =
-CLEANFILES =
-DISTCLEANFILES =
libexec_PROGRAMS = indicator-messages-service
-
-######################################
-# Building the messages indicator
-######################################
-
-messaginglibdir = $(INDICATORDIR)
-messaginglib_LTLIBRARIES = libmessaging.la
-libmessaging_la_SOURCES = \
- indicator-messages.c \
- ido-menu-item.c \
- ido-menu-item.h \
- im-app-menu-item.c \
- im-app-menu-item.h \
- im-source-menu-item.c \
- im-source-menu-item.h \
- ido-detail-label.c \
- ido-detail-label.h \
- indicator-messages-service.c \
- indicator-messages-service.h
- dbus-data.h
-libmessaging_la_CFLAGS = \
- $(APPLET_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -Wall \
- -Wl,-Bsymbolic-functions \
- -Wl,-z,defs \
- -Wl,--as-needed \
- -Werror \
- -DG_LOG_DOMAIN=\"Indicator-Messages\"
-libmessaging_la_LIBADD = $(APPLET_LIBS) -lm
-libmessaging_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
- -module -avoid-version
-
-######################################
-# Building the messages service
-######################################
-
indicator_messages_service_SOURCES = \
messages-service.c \
- indicator-messages-service.c \
- indicator-messages-service.h \
app-section.c \
app-section.h \
dbus-data.h \
@@ -56,11 +13,22 @@ indicator_messages_service_SOURCES = \
gsettingsstrv.c \
gsettingsstrv.h \
gmenuutils.c \
- gmenuutils.h
+ gmenuutils.h \
+ im-menu.c \
+ im-menu.h \
+ im-phone-menu.c \
+ im-phone-menu.h \
+ im-desktop-menu.c \
+ im-desktop-menu.h \
+ im-application-list.c \
+ im-application-list.h \
+ indicator-desktop-shortcuts.c \
+ indicator-desktop-shortcuts.h
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \
$(COVERAGE_CFLAGS) \
+ -I$(top_builddir)/common \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -69,26 +37,11 @@ indicator_messages_service_CFLAGS = \
-DG_LOG_DOMAIN=\"Indicator-Messages\"
indicator_messages_service_LDADD = \
+ $(top_builddir)/common/libmessaging-common.la \
$(APPLET_LIBS)
indicator_messages_service_LDFLAGS = \
$(COVERAGE_LDFLAGS)
-indicator-messages-service.c: $(top_srcdir)/src/messages-service.xml
- $(AM_V_GEN) gdbus-codegen \
- --interface-prefix com.canonical.indicator.messages. \
- --generate-c-code indicator-messages-service \
- --c-namespace IndicatorMessages \
- $^
-indicator-messages-service.h: indicator-messages-service.c
-
-BUILT_SOURCES += \
- indicator-messages-service.c \
- indicator-messages-service.h
-
EXTRA_DIST += \
messages-service.xml
-
-CLEANFILES += \
- $(BUILT_SOURCES)
-