aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-02-25 19:34:56 -0500
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-02-25 19:34:56 -0500
commit5c47f6dbe75e413d2acbcef3e9750e937fb18431 (patch)
treefce3bfab963100972280fe4d61df903c5e20c7db /test/Makefile.am
parent8249e264e0f426d6702d21a690477be495045f90 (diff)
downloadayatana-indicator-messages-5c47f6dbe75e413d2acbcef3e9750e937fb18431.tar.gz
ayatana-indicator-messages-5c47f6dbe75e413d2acbcef3e9750e937fb18431.tar.bz2
ayatana-indicator-messages-5c47f6dbe75e413d2acbcef3e9750e937fb18431.zip
Test libmessaging-menu
Use dbusmock to test whether libmessaging-menu calls the right functions on registration and deregistration.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4671446..87ae2c3 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -65,3 +65,13 @@ libindicator_messages_service_la_LIBADD = \
libindicator_messages_service_la_LDFLAGS = \
$(COVERAGE_LDFLAGS)
+
+######################################
+# Test client with dbusmock
+######################################
+
+TESTS_ENVIRONMENT = \
+ export LD_LIBRARY_PATH=$(top_builddir)/libmessaging-menu/.libs; \
+ export GI_TYPELIB_PATH=$(top_builddir)/libmessaging-menu;
+
+TESTS += test-client.py