aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-06-04 18:13:24 +0200
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-06-04 18:13:24 +0200
commit7d4fcf06c92e71fa0abb1927ac21705ab88478c0 (patch)
tree0218fb471b181caf82665a01ce968989b0aa1ef2 /test/Makefile.am
parent3eb45ac840a66511537cdf2bd2c9f7c68c6e1761 (diff)
downloadayatana-indicator-messages-7d4fcf06c92e71fa0abb1927ac21705ab88478c0.tar.gz
ayatana-indicator-messages-7d4fcf06c92e71fa0abb1927ac21705ab88478c0.tar.bz2
ayatana-indicator-messages-7d4fcf06c92e71fa0abb1927ac21705ab88478c0.zip
Add a first gactionmuxer test
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 977c1ed..f1ab408 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,6 +1,6 @@
check_LIBRARIES = libgtest.a
-check_PROGRAMS = test-gtest
+check_PROGRAMS = test-gtest test-gactionmuxer
TESTS =
@@ -31,6 +31,17 @@ test_gtest_LDADD = \
libgtest.a
+TESTS += test-gactionmuxer
+
+test_gactionmuxer_SOURCES = \
+ test-gactionmuxer.cpp \
+ $(top_srcdir)/src/gactionmuxer.c \
+ $(top_srcdir)/src/gactionmuxer.h
+
+test_gactionmuxer_CPPFLAGS = $(APPLET_CFLAGS) $(AM_CPPFLAGS)
+test_gactionmuxer_LDADD = $(APPLET_LIBS) libgtest.a
+
+
######################################
# Lib containing code under test
######################################