aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-03-06 09:00:05 -0600
committerTed Gould <ted@gould.cx>2015-03-06 09:00:05 -0600
commit8ac8ca2cd9375cc3d9cdf7e50b9f07dad6c4ef8e (patch)
tree99b51735c0d0b1c6c68f76d744e220a08cec82b3 /test/Makefile.am
parentdbd3db2c833f9b02fb8e399551e977cf950cf559 (diff)
downloadayatana-indicator-messages-8ac8ca2cd9375cc3d9cdf7e50b9f07dad6c4ef8e.tar.gz
ayatana-indicator-messages-8ac8ca2cd9375cc3d9cdf7e50b9f07dad6c4ef8e.tar.bz2
ayatana-indicator-messages-8ac8ca2cd9375cc3d9cdf7e50b9f07dad6c4ef8e.zip
One test directory to rule them all
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am77
1 files changed, 0 insertions, 77 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
deleted file mode 100644
index b679615..0000000
--- a/test/Makefile.am
+++ /dev/null
@@ -1,77 +0,0 @@
-
-check_LIBRARIES = libgtest.a
-check_PROGRAMS = test-gactionmuxer
-
-TESTS = $(check_PROGRAMS)
-
-AM_CPPFLAGS = $(GTEST_CPPFLAGS) \
- -I${top_srcdir}/src
-
-nodist_libgtest_a_SOURCES = \
- $(GTEST_SOURCE)/src/gtest-all.cc \
- $(GTEST_SOURCE)/src/gtest_main.cc
-libgtest_a_CPPFLAGS = \
- $(GTEST_CPPFLAGS) -w \
- $(AM_CPPFLAGS)
-libgtest_a_CXXFLAGS = \
- $(AM_CXXFLAGS)
-
-
-test_gactionmuxer_SOURCES = \
- test-gactionmuxer.cpp
-
-test_gactionmuxer_CPPFLAGS = \
- $(APPLET_CFLAGS) \
- $(AM_CPPFLAGS)
-
-test_gactionmuxer_LDADD = \
- $(APPLET_LIBS) \
- libindicator-messages-service.la \
- libgtest.a
-
-
-######################################
-# Lib containing code under test
-######################################
-
-noinst_LTLIBRARIES = \
- libindicator-messages-service.la
-
-libindicator_messages_service_la_SOURCES = \
- $(top_builddir)/common/indicator-messages-service.c \
- $(top_builddir)/common/indicator-messages-service.h \
- $(top_srcdir)/src/gactionmuxer.c \
- $(top_srcdir)/src/gactionmuxer.h
- $(top_srcdir)/src/dbus-data.h
-
-libindicator_messages_service_ladir = \
- $(includedir)/libindicator-messages-service/
-
-libindicator_messages_service_la_CFLAGS = \
- $(APPLET_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -I$(top_builddir)/src \
- -I$(top_builddir)/common \
- -Wall \
- -Wl,-Bsymbolic-functions \
- -Wl,-z,defs \
- -Wl,--as-needed \
- -Werror -Wno-error=deprecated-declarations \
- -DG_LOG_DOMAIN=\"Indicator-Messages\"
-
-libindicator_messages_service_la_LIBADD = \
- $(APPLET_LIBS)
-
-libindicator_messages_service_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS)
-
-######################################
-# Test client with dbusmock
-######################################
-
-TESTS_ENVIRONMENT = \
- export LD_LIBRARY_PATH=$(top_builddir)/libmessaging-menu/.libs; \
- export GI_TYPELIB_PATH=$(top_builddir)/libmessaging-menu; \
- export XDG_DATA_DIRS=$(abs_srcdir);
-
-TESTS += test-client.py