aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am23
1 files changed, 15 insertions, 8 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 60dd839..b88aee5 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
SUBDIRS = icons
xdg_autostartdir = /etc/xdg/autostart
@@ -6,23 +8,28 @@ xdg_autostart_DATA = ayatana-indicator-messages.desktop
%.desktop: %.desktop.in
$(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
-upstart_jobsdir = $(datadir)/upstart/sessions/
-upstart_jobs_DATA = ayatana-indicator-messages.conf
+gsettings_SCHEMAS = org.ayatana.indicator.messages.gschema.xml
+@GSETTINGS_RULES@
-%.conf: %.conf.in
+#if defined(HAVE_SYSTEMD)
+systemdservice_file = ayatana-indicator-messages.service
+$(systemdservice_file): $(systemdservice_file).in
$(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
-gsettings_SCHEMAS = org.ayatana.indicator.messages.gschema.xml
-@GSETTINGS_RULES@
+systemddir = $(SYSTEMD_USERDIR)
+systemd_DATA = $(systemdservice_file)
+#endif
indicatordir = $(INDICATOR_DIR)
dist_indicator_DATA = org.ayatana.indicator.messages
EXTRA_DIST = \
ayatana-indicator-messages.desktop.in \
- ayatana-indicator-messages.conf.in \
- $(gsettings_SCHEMAS)
+ $(gsettings_SCHEMAS) \
+ $(systemdservice_file).in \
+ $(NULL)
CLEANFILES = \
$(xdg_autostart_DATA) \
- $(upstart_jobs_DATA)
+ $(systemdservice_file) \
+ $(NULL)