aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am71
1 files changed, 60 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e03406a..1df80e5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,10 +1,53 @@
+BUILT_SOURCES =
EXTRA_DIST =
+CLEANFILES =
+DISTCLEANFILES =
libexec_PROGRAMS = indicator-messages-service
+
+######################################
+# Building the messages indicator
+######################################
+
+messaginglibdir = $(INDICATORDIR)
+messaginglib_LTLIBRARIES = libmessaging.la
+libmessaging_la_SOURCES = \
+ indicator-messages.c \
+ ido-menu-item.c \
+ ido-menu-item.h \
+ im-app-menu-item.c \
+ im-app-menu-item.h \
+ im-source-menu-item.c \
+ im-source-menu-item.h \
+ ido-detail-label.c \
+ ido-detail-label.h \
+ indicator-messages-service.c \
+ indicator-messages-service.h
+ dbus-data.h
+libmessaging_la_CFLAGS = \
+ $(APPLET_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ -Wall \
+ -Wl,-Bsymbolic-functions \
+ -Wl,-z,defs \
+ -Wl,--as-needed \
+ -Werror \
+ -DG_LOG_DOMAIN=\"Indicator-Messages\"
+libmessaging_la_LIBADD = $(APPLET_LIBS) -lm
+libmessaging_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
+
+######################################
+# Building the messages service
+######################################
+
indicator_messages_service_SOURCES = \
messages-service.c \
+ indicator-messages-service.c \
+ indicator-messages-service.h \
app-section.c \
app-section.h \
dbus-data.h \
@@ -13,20 +56,11 @@ indicator_messages_service_SOURCES = \
gsettingsstrv.c \
gsettingsstrv.h \
gmenuutils.c \
- gmenuutils.h \
- im-menu.c \
- im-menu.h \
- im-phone-menu.c \
- im-phone-menu.h \
- im-desktop-menu.c \
- im-desktop-menu.h \
- im-application-list.c \
- im-application-list.h
+ gmenuutils.h
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \
$(COVERAGE_CFLAGS) \
- -I$(top_builddir)/common \
-Wall \
-Wl,-Bsymbolic-functions \
-Wl,-z,defs \
@@ -35,11 +69,26 @@ indicator_messages_service_CFLAGS = \
-DG_LOG_DOMAIN=\"Indicator-Messages\"
indicator_messages_service_LDADD = \
- $(top_builddir)/common/libmessaging-common.la \
$(APPLET_LIBS)
indicator_messages_service_LDFLAGS = \
$(COVERAGE_LDFLAGS)
+indicator-messages-service.c: $(top_srcdir)/src/messages-service.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-service \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-service.h: indicator-messages-service.c
+
+BUILT_SOURCES += \
+ indicator-messages-service.c \
+ indicator-messages-service.h
+
EXTRA_DIST += \
messages-service.xml
+
+CLEANFILES += \
+ $(BUILT_SOURCES)
+