aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6ceb1d4..a790ba2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,7 +2,7 @@
check_LIBRARIES = libgtest.a
check_PROGRAMS = test-gactionmuxer
-TESTS =
+TESTS = $(check_PROGRAMS)
AM_CPPFLAGS = $(GTEST_CPPFLAGS) \
-I${top_srcdir}/src
@@ -11,13 +11,11 @@ nodist_libgtest_a_SOURCES = \
$(GTEST_SOURCE)/src/gtest-all.cc \
$(GTEST_SOURCE)/src/gtest_main.cc
libgtest_a_CPPFLAGS = \
- $(GTEST_CPPFLAGS) -w
+ $(GTEST_CPPFLAGS) -w \
+ $(AM_CPPFLAGS)
libgtest_a_CXXFLAGS = \
$(AM_CXXFLAGS)
-libgtest_a_CPPFLAGS = \
- $(AM_CPPFLAGS)
-TESTS += test-gactionmuxer
test_gactionmuxer_SOURCES = \
test-gactionmuxer.cpp \