aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 977c1ed..f1ab408 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,6 +1,6 @@
check_LIBRARIES = libgtest.a
-check_PROGRAMS = test-gtest
+check_PROGRAMS = test-gtest test-gactionmuxer
TESTS =
@@ -31,6 +31,17 @@ test_gtest_LDADD = \
libgtest.a
+TESTS += test-gactionmuxer
+
+test_gactionmuxer_SOURCES = \
+ test-gactionmuxer.cpp \
+ $(top_srcdir)/src/gactionmuxer.c \
+ $(top_srcdir)/src/gactionmuxer.h
+
+test_gactionmuxer_CPPFLAGS = $(APPLET_CFLAGS) $(AM_CPPFLAGS)
+test_gactionmuxer_LDADD = $(APPLET_LIBS) libgtest.a
+
+
######################################
# Lib containing code under test
######################################