aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-09-06 14:30:00 +0200
committerRobert Tari <robert@tari.in>2023-09-06 14:30:00 +0200
commit8f3234c2cf7a543c88fcc28caed93521a81f6ffa (patch)
tree41e7aeb00b6dd3bfe942e61132e836ece12ee634 /CMakeLists.txt
parentcd22a9eb1d2d85f11a4e6fbe4bbda5691c193f63 (diff)
downloadayatana-indicator-notifications-8f3234c2cf7a543c88fcc28caed93521a81f6ffa.tar.gz
ayatana-indicator-notifications-8f3234c2cf7a543c88fcc28caed93521a81f6ffa.tar.bz2
ayatana-indicator-notifications-8f3234c2cf7a543c88fcc28caed93521a81f6ffa.zip
Drop testing/coverage options
fixes https://github.com/AyatanaIndicators/ayatana-indicator-notifications/issues/30
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 4 insertions, 25 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2024c8..2d5a7ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,21 +1,10 @@
-project(ayatana-indicator-notifications C CXX)
-cmake_minimum_required(VERSION 3.13)
-
-set(PROJECT_VERSION "22.9.0")
-set(PACKAGE ${CMAKE_PROJECT_NAME})
+cmake_minimum_required (VERSION 3.13)
+project (ayatana-indicator-notifications VERSION 22.9.0 LANGUAGES C CXX)
# Options
-option(ENABLE_TESTS "Enable all tests and checks" OFF)
-option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
-
-if(ENABLE_COVERAGE)
- set(ENABLE_TESTS ON)
- set(CMAKE_BUILD_TYPE "Coverage")
-else()
- set(CMAKE_BUILD_TYPE "Release")
-endif()
+set (CMAKE_BUILD_TYPE "Release")
if(ENABLE_WERROR)
add_definitions("-Werror")
@@ -60,7 +49,7 @@ include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})
## custom targets
##
-set (ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${PROJECT_VERSION})
+set (ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${CMAKE_PROJECT_VERSION})
add_custom_target (dist
COMMAND bzr export --root=${ARCHIVE_NAME} ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.gz
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
@@ -79,17 +68,7 @@ add_subdirectory(src)
add_subdirectory(data)
add_subdirectory(po)
-if (ENABLE_TESTS)
- include(CTest)
- enable_testing()
-
- if (ENABLE_COVERAGE)
- find_package(CoverageReport)
- endif()
-endif()
-
# Display config info
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
-message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")