aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-11-12 14:46:31 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-11-12 14:46:31 +0100
commit2219106afbbb3fb5a6965ecb1454094d57ca0672 (patch)
treeed2db0f27964d4c12aa188380c1f979379b2a780 /src/CMakeLists.txt
parent4fd70a531c949e4667c33ba58d7555bfc7e5e148 (diff)
parent7d16f615214827d4265730d9f7bbd7fee9abcfc7 (diff)
downloadayatana-indicator-notifications-2219106afbbb3fb5a6965ecb1454094d57ca0672.tar.gz
ayatana-indicator-notifications-2219106afbbb3fb5a6965ecb1454094d57ca0672.tar.bz2
ayatana-indicator-notifications-2219106afbbb3fb5a6965ecb1454094d57ca0672.zip
Merge branch 'tari01-pr/url-dispatcher'
Attributes GH PR #14: https://github.com/AyatanaIndicators/ayatana-indicator-notifications/pull/14
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index eaebc58..9a19244 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -3,10 +3,6 @@ set (SERVICE_EXEC "ayatana-indicator-notifications-service")
add_definitions(-DG_LOG_DOMAIN="ayatana-indicator-notifications")
-if(URLDISPATCHER_FOUND)
- add_definitions( -DHAS_URLDISPATCHER )
-endif()
-
# handwritten sources
set(SERVICE_MANUAL_SOURCES
urlregex.c
@@ -37,5 +33,5 @@ link_directories(${SERVICE_DEPS_LIBRARY_DIRS})
# the executable: lib + main()
add_executable (${SERVICE_EXEC} main.c)
set_source_files_properties(${SERVICE_SOURCES} main.c PROPERTIES COMPILE_FLAGS "${C_WARNING_ARGS} -std=c99")
-target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES} ${URLDISPATCHER_LIBRARIES})
+target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES})
install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})