aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5cbce14..e89ade2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,10 +7,12 @@ libayatana_notifications_la_SOURCES = \
urlregex.h \
notification-menuitem.c \
notification-menuitem.h \
+ settings.h \
indicator-notifications.c \
notification.c \
notification.h
libayatana_notifications_la_CFLAGS = \
+ -DSETTINGS_PATH=\""$(libexecdir)/$(PACKAGE)/indicator-notifications-settings"\" \
$(INDICATOR_CFLAGS) \
-Wall \
-DG_LOG_DOMAIN=\"ayatana-indicator-notifications\"
@@ -20,3 +22,15 @@ libayatana_notifications_la_LDFLAGS = \
-module \
-avoid-version
+pkglibexec_PROGRAMS = indicator-notifications-settings
+
+indicator_notifications_settings_SOURCES = \
+ settings.h \
+ indicator-notifications-settings.c
+
+indicator_notifications_settings_CFLAGS = \
+ $(SETTINGS_CFLAGS) \
+ -Wall
+
+indicator_notifications_settings_LDADD = \
+ $(SETTINGS_LIBS)